summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-21 21:56:36 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-21 21:56:36 +0000
commit54e0ecd58324f1e1696bff606809ee1d2a894467 (patch)
tree9e3e7b3cab54c7f03d190635a98d2289d97596eb /dev-ruby/gherkin
parentRemove unused file. (diff)
downloadhistorical-54e0ecd58324f1e1696bff606809ee1d2a894467.tar.gz
historical-54e0ecd58324f1e1696bff606809ee1d2a894467.tar.bz2
historical-54e0ecd58324f1e1696bff606809ee1d2a894467.zip
Remove unused file. Cleanup fakegem ebuild to actually work.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'dev-ruby/gherkin')
-rw-r--r--dev-ruby/gherkin/ChangeLog6
-rw-r--r--dev-ruby/gherkin/files/gherkin-1.0.24-fix-specs.patch29
-rw-r--r--dev-ruby/gherkin/gherkin-1.0.30.ebuild10
3 files changed, 11 insertions, 34 deletions
diff --git a/dev-ruby/gherkin/ChangeLog b/dev-ruby/gherkin/ChangeLog
index 239f07605a29..9f410af7a008 100644
--- a/dev-ruby/gherkin/ChangeLog
+++ b/dev-ruby/gherkin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/gherkin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/ChangeLog,v 1.9 2010/07/21 08:00:09 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/ChangeLog,v 1.10 2010/08/21 21:56:36 flameeyes Exp $
+
+ 21 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ -files/gherkin-1.0.24-fix-specs.patch, gherkin-1.0.30.ebuild:
+ Remove unused file. Cleanup fakegem ebuild to actually work.
21 Jul 2010; Hans de Graaff <graaff@gentoo.org> gherkin-1.0.30.ebuild:
Add missing dependency on rake-compiler and fix rspec dependency according
diff --git a/dev-ruby/gherkin/files/gherkin-1.0.24-fix-specs.patch b/dev-ruby/gherkin/files/gherkin-1.0.24-fix-specs.patch
deleted file mode 100644
index 6c6cc65e9557..000000000000
--- a/dev-ruby/gherkin/files/gherkin-1.0.24-fix-specs.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-commit 20941d84343e6bf0c036fb2ae65a121e143ff334
-Author: aslakhellesoy <aslak.hellesoy@gmail.com>
-Date: Sun May 9 00:36:59 2010 +0200
-
- Remove require of removed file. (I never saw the error because the file was found in an old gherkin gem I had installed) Closes #59
-
-diff --git a/History.txt b/History.txt
-index 7bf86c9..3755af6 100644
---- a/History.txt
-+++ b/History.txt
-@@ -1,3 +1,8 @@
-+== 1.0.25 (2010-05-02)
-+
-+=== Bugfixes
-+* Can't run specs in gherkin 1.0.24 (#59 Aslak Hellesøy)
-+
- == 1.0.24 (2010-05-02)
-
- === Bugfixes
-diff --git a/ragel/lexer.rb.rl.erb b/ragel/lexer.rb.rl.erb
-index e600b7a..a2d26cc 100644
---- a/ragel/lexer.rb.rl.erb
-+++ b/ragel/lexer.rb.rl.erb
-@@ -1,5 +1,3 @@
--require 'gherkin/core_ext/array'
--
- module Gherkin
- module RbLexer
- class <%= @i18n.underscored_iso_code.capitalize %> #:nodoc:
diff --git a/dev-ruby/gherkin/gherkin-1.0.30.ebuild b/dev-ruby/gherkin/gherkin-1.0.30.ebuild
index 26a44c83f307..c9c316c9c119 100644
--- a/dev-ruby/gherkin/gherkin-1.0.30.ebuild
+++ b/dev-ruby/gherkin/gherkin-1.0.30.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/gherkin-1.0.30.ebuild,v 1.2 2010/07/21 08:00:09 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/gherkin-1.0.30.ebuild,v 1.3 2010/08/21 21:56:36 flameeyes Exp $
EAPI=2
USE_RUBY="ruby18"
@@ -23,13 +23,15 @@ IUSE=""
DEPEND="${DEPEND} dev-util/ragel"
-ruby_add_bdepend ">=dev-ruby/rspec-1.3.0 >=dev-ruby/rake-compiler-0.7.0"
-ruby_add_bdepend "test? ( >=dev-util/cucumber-0.7.0 )"
+ruby_add_bdepend "
+ >=dev-ruby/rspec-1.3.0
+ >=dev-ruby/rake-compiler-0.7.0
+ test? ( >=dev-util/cucumber-0.7.0 )"
ruby_add_rdepend ">=dev-ruby/trollop-1.16.2"
each_ruby_compile() {
- ${RUBY} -I lib -S rake compile
+ ${RUBY} -I lib -S rake compile || die
}
each_ruby_test() {