summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-12-08 06:19:56 +0000
committerTim Harder <radhermit@gentoo.org>2012-12-08 06:19:56 +0000
commitf49716eb735a92f06c6a0306674ed27aff312e5b (patch)
tree9725f3427866a1d233c770a3db19e278e3bc844e /dev-util/ltrace/ltrace-0.7.2.ebuild
parentRESTRICT=bindist. (diff)
downloadhistorical-f49716eb735a92f06c6a0306674ed27aff312e5b.tar.gz
historical-f49716eb735a92f06c6a0306674ed27aff312e5b.tar.bz2
historical-f49716eb735a92f06c6a0306674ed27aff312e5b.zip
Version bump.
Package-Manager: portage-2.2.0_alpha144/cvs/Linux x86_64 Manifest-Sign-Key: 0x4AB3E85B4F064CA3
Diffstat (limited to 'dev-util/ltrace/ltrace-0.7.2.ebuild')
-rw-r--r--dev-util/ltrace/ltrace-0.7.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/ltrace/ltrace-0.7.2.ebuild b/dev-util/ltrace/ltrace-0.7.2.ebuild
new file mode 100644
index 000000000000..627466dde59a
--- /dev/null
+++ b/dev-util/ltrace/ltrace-0.7.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ltrace/ltrace-0.7.2.ebuild,v 1.1 2012/12/08 06:19:51 radhermit Exp $
+
+EAPI=5
+
+inherit eutils autotools
+
+NUM="3848"
+
+DESCRIPTION="trace library calls made at runtime"
+HOMEPAGE="http://ltrace.alioth.debian.org/"
+SRC_URI="https://alioth.debian.org/frs/download.php/${NUM}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="debug test unwind"
+
+RDEPEND="dev-libs/elfutils
+ unwind? ( sys-libs/libunwind )"
+DEPEND="${RDEPEND}
+ test? ( dev-util/dejagnu )"
+
+src_prepare() {
+ sed -i '/^dist_doc_DATA/d' Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-werror \
+ $(use_enable debug) \
+ $(use_with unwind libunwind)
+}