summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-03-26 00:56:27 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-03-26 00:56:27 +0000
commit2cced508b10742b45e5223c9dd9d1d75d49402b7 (patch)
tree6a1476890de290da69c1d76c4682fb1aa1b941e5 /dev-util/poedit
parentrequired for resin. (diff)
downloadhistorical-2cced508b10742b45e5223c9dd9d1d75d49402b7.tar.gz
historical-2cced508b10742b45e5223c9dd9d1d75d49402b7.tar.bz2
historical-2cced508b10742b45e5223c9dd9d1d75d49402b7.zip
this time it really will fix the bug
Diffstat (limited to 'dev-util/poedit')
-rw-r--r--dev-util/poedit/ChangeLog5
-rw-r--r--dev-util/poedit/poedit-1.2.1.ebuild25
2 files changed, 16 insertions, 14 deletions
diff --git a/dev-util/poedit/ChangeLog b/dev-util/poedit/ChangeLog
index 1005178a658f..2a8763d0fa84 100644
--- a/dev-util/poedit/ChangeLog
+++ b/dev-util/poedit/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for dev-util/poedit
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/poedit/ChangeLog,v 1.7 2003/03/25 02:14:23 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/poedit/ChangeLog,v 1.8 2003/03/26 00:56:27 liquidx Exp $
*poedit-1.2.1 (08 Mar 2003)
+ 26 Mar 2003; Alastair Tse <liquidx@gentoo.org> poedit-1.2.1.ebuild:
+ really fix the KDEDIR problem. Bug #17981.
+
25 Mar 2003; Alastair Tse <liquidx@gentoo.org> poedit-1.2.1.ebuild:
added correct KDE install paths
diff --git a/dev-util/poedit/poedit-1.2.1.ebuild b/dev-util/poedit/poedit-1.2.1.ebuild
index 1340410c72bf..48d50013e5d0 100644
--- a/dev-util/poedit/poedit-1.2.1.ebuild
+++ b/dev-util/poedit/poedit-1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/poedit/poedit-1.2.1.ebuild,v 1.3 2003/03/25 02:14:23 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/poedit/poedit-1.2.1.ebuild,v 1.4 2003/03/26 00:56:27 liquidx Exp $
inherit eutils kde
@@ -15,26 +15,25 @@ KEYWORDS="x86 ~sparc"
DEPEND=">=x11-libs/wxGTK-2.3.4
>=sys-libs/db-3"
-src_unpack() {
- unpack ${A}
-
- cd ${S}
- epatch ${FILESDIR}/${P}-gentoo_make_paths.patch
-}
-
src_compile() {
- autoconf
- automake
-
econf || die
emake || die
}
src_install () {
+
+ # in case KDEDIR is empty
+ local MY_KDEDIR
+ if [ -n "${KDEDIR}" ]; then
+ MY_KDEDIR=${KDEDIR}
+ else
+ MY_KDEDIR=/usr
+ fi
+
einstall \
datadir=${D}/usr/share \
- GNOME_DATA_DIR=${D}/usr/share || die
- KDE_DATA_DIR=${D}/${KDEDIR}/share || die
+ GNOME_DATA_DIR=${D}/usr/share \
+ KDE_DATA_DIR=${D}/${MY_KDEDIR}/share || die
dodoc AUTHORS LICENSE NEWS README TODO
}