summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-11-18 13:38:20 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-11-18 13:38:20 +0000
commit9e09441743c96576027536b89d6f16db34411a39 (patch)
tree4992a11cc653e51e7b7df912ff2cb65e94ccdad4 /games-action
parentMove x11-libs/evas to media-libs/evas (diff)
downloadhistorical-9e09441743c96576027536b89d6f16db34411a39.tar.gz
historical-9e09441743c96576027536b89d6f16db34411a39.tar.bz2
historical-9e09441743c96576027536b89d6f16db34411a39.zip
Version bump to 0.3.1 Bug #341895
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'games-action')
-rw-r--r--games-action/violetland/ChangeLog7
-rw-r--r--games-action/violetland/Manifest4
-rw-r--r--games-action/violetland/violetland-0.3.1.ebuild54
3 files changed, 63 insertions, 2 deletions
diff --git a/games-action/violetland/ChangeLog b/games-action/violetland/ChangeLog
index c9c2c8b6fa65..69b4a67696ed 100644
--- a/games-action/violetland/ChangeLog
+++ b/games-action/violetland/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/violetland
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/ChangeLog,v 1.12 2010/07/10 14:40:07 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/ChangeLog,v 1.13 2010/11/18 13:38:20 tupone Exp $
+
+*violetland-0.3.1 (18 Nov 2010)
+
+ 18 Nov 2010; Alfredo Tupone <tupone@gentoo.org> +violetland-0.3.1.ebuild:
+ Version bump to 0.3.1 Bug #341895 by Azamat H. Hackimov
10 Jul 2010; Christian Faulhammer <fauli@gentoo.org>
violetland-0.3.0.ebuild:
diff --git a/games-action/violetland/Manifest b/games-action/violetland/Manifest
index a6952c3eba2e..6c73d7a82212 100644
--- a/games-action/violetland/Manifest
+++ b/games-action/violetland/Manifest
@@ -1,4 +1,6 @@
DIST violetland-v0.3.0-src.zip 8957643 RMD160 89225eb33a87b965e040973c9f24a128b970282e SHA1 8497b1de644cebccbc0841e8010f12a35c0a497d SHA256 537332ab4e9fd92c23d0fab81f7133071ae3a78bb7020c0f7b2c725ce9cce3eb
+DIST violetland-v0.3.1-src.zip 9208016 RMD160 9cb716cde7d212126e4addff3062b3cfd7bb3131 SHA1 7b50cd7aa2182e8fffbf2ac9487201066a95419b SHA256 27d9da8ca7696ed1654a59a279a71ad224b46bf984d1e8257f3606e81f062db5
EBUILD violetland-0.3.0.ebuild 1274 RMD160 c5e270cc392ac2adf7624ed2a79c144bab4902d8 SHA1 6a999494bdf2620477715ea3f9b957c156d41eac SHA256 f6111fcbc9b2065218577a65aea6f8a979566240ff10fe7565392cd266d8d5ad
-MISC ChangeLog 1810 RMD160 b72c1e2801f74edd193a77bfc3ba9f565a087d10 SHA1 3f426cd18836ef734953e79ed4d98fa5ec54a8b4 SHA256 10115ab3bf669fab8c642bc9d82f52eae11914c84f1d2968c8fd080c83472e65
+EBUILD violetland-0.3.1.ebuild 1277 RMD160 50f05f91b7cba55b32a69e9df3c3d1a2f626b4f0 SHA1 fcf10258a21eebb964946892d1521694e7085c3a SHA256 13fcbe045ae9c3e9641b40a3ce17c8cbe8331bc642d334e61cdda3889523fcec
+MISC ChangeLog 1979 RMD160 75ef1f4ed38d682c13d9201c65b96970ef170c0a SHA1 a4e5c224b9aba68ab054e611e2b87086171207cf SHA256 21afaf777861f5b0e23ccd0d56a43d7a5baf0306cc3974702ee1870248279cb5
MISC metadata.xml 158 RMD160 cbd9984bb6b426c8c9cee5022fe0a26261612fea SHA1 be5251fa1dacef5c41b74761bb1c8c54fb633b9e SHA256 1423a4fdd4a79b1728a2056d9e300f7e1074253095d82726218d9e9b953888a3
diff --git a/games-action/violetland/violetland-0.3.1.ebuild b/games-action/violetland/violetland-0.3.1.ebuild
new file mode 100644
index 000000000000..5496d813b222
--- /dev/null
+++ b/games-action/violetland/violetland-0.3.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/violetland-0.3.1.ebuild,v 1.1 2010/11/18 13:38:20 tupone Exp $
+
+EAPI=2
+inherit eutils cmake-utils games
+
+DESCRIPTION="Help a girl by name of Violet to struggle with hordes of monsters."
+HOMEPAGE="http://code.google.com/p/violetland/"
+SRC_URI="http://violetland.googlecode.com/files/${PN}-v${PV}-src.zip"
+
+LICENSE="GPL-3 CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[audio,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-ttf
+ x11-libs/libXext
+ x11-libs/libSM
+ virtual/opengl
+ virtual/glu"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}-v${PV}
+
+src_prepare() {
+ sed -i \
+ -e "/README_EN.TXT/d" \
+ -e "/README_RU.TXT/d" \
+ CMakeLists.txt || die "sed failed"
+}
+
+src_configure() {
+ mycmakeargs=(
+ "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
+ "-DDATA_INSTALL_DIR=${GAMES_DATADIR}"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ DOCS="README_EN.TXT CHANGELOG" cmake-utils_src_install
+ newicon icon-light.png ${PN}.png
+ make_desktop_entry ${PN} VioletLand
+ prepgamesdirs
+}