summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2007-04-06 00:10:19 +0000
committerTristan Heaven <tristan@gentoo.org>2007-04-06 00:10:19 +0000
commitca2ac27e0bd8462d9d66cb40c87482356cdcf8b4 (patch)
treef0d7bd8e2f2746d325dd9b647022bf14dd1e28b9 /games-arcade/bub-n-bros
parentVersion bump thanks to Per Pomsel <phantom4@gmx.net> in bug 173465 (diff)
downloadhistorical-ca2ac27e0bd8462d9d66cb40c87482356cdcf8b4.tar.gz
historical-ca2ac27e0bd8462d9d66cb40c87482356cdcf8b4.tar.bz2
historical-ca2ac27e0bd8462d9d66cb40c87482356cdcf8b4.zip
use games_get_libdir
Package-Manager: portage-2.1.2.3
Diffstat (limited to 'games-arcade/bub-n-bros')
-rw-r--r--games-arcade/bub-n-bros/bub-n-bros-1.1.ebuild31
-rw-r--r--games-arcade/bub-n-bros/files/bubnbros-server3
2 files changed, 15 insertions, 19 deletions
diff --git a/games-arcade/bub-n-bros/bub-n-bros-1.1.ebuild b/games-arcade/bub-n-bros/bub-n-bros-1.1.ebuild
index 6af0d940a9c4..d0c1572244f9 100644
--- a/games-arcade/bub-n-bros/bub-n-bros-1.1.ebuild
+++ b/games-arcade/bub-n-bros/bub-n-bros-1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/bub-n-bros/bub-n-bros-1.1.ebuild,v 1.11 2007/03/12 13:22:54 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/bub-n-bros/bub-n-bros-1.1.ebuild,v 1.12 2007/04/06 00:08:25 nyhm Exp $
inherit games
@@ -16,38 +16,37 @@ IUSE=""
DEPEND=">=dev-lang/python-2.2"
RDEPEND=">=dev-python/pygame-1.5.5"
-S="${WORKDIR}/${PN}"
+S=${WORKDIR}/${PN}
src_compile() {
# Compile the "statesaver" extension module to enable the Clock bonus
- cd ${S}/bubbob
+ cd "${S}"/bubbob
python setup.py build_ext -i || die
# Compile the extension module required for the X Window client
- cd ${S}/display
+ cd "${S}"/display
python setup.py build_ext -i || die
}
src_install() {
- local dir=${GAMES_LIBDIR}/${PN}
+ local dir=$(games_get_libdir)/${PN}
- exeinto ${dir}
- doexe *.py
+ exeinto "${dir}"
+ doexe *.py || die "doexe failed"
- insinto ${dir}
- cp -r bubbob common display java ${D}/${dir}/
+ insinto "${dir}"
+ doins -r bubbob common display java || die "doins failed"
- dodir ${GAMES_BINDIR}
- dosym ${dir}/pclient-pygame.py ${GAMES_BINDIR}/bubnbros
- dosym ${dir}/pclient-xshm.py ${GAMES_BINDIR}/bubnbros-x
- dosym ${dir}/pclient-slow-X.py ${GAMES_BINDIR}/bubnbros-slowx
+ dodir "${GAMES_BINDIR}"
+ dosym "${dir}"/pclient-pygame.py "${GAMES_BINDIR}"/bubnbros
+ dosym "${dir}"/pclient-xshm.py "${GAMES_BINDIR}"/bubnbros-x
+ dosym "${dir}"/pclient-slow-X.py "${GAMES_BINDIR}"/bubnbros-slowx
- dogamesbin ${FILESDIR}/bubnbros-server
- dosed "s:GENTOO_DIR:${dir}/bubbob/:" ${GAMES_BINDIR}/bubnbros-server
+ games_make_wrapper bubnbros-server "python ./bb.py" "${dir}"/bubbob
dohtml *.html
- find ${D}/${dir} -name CVS -type d -exec rm -rf '{}' \; 2> /dev/null
+ find "${D}/${dir}" -name CVS -type d -exec rm -rf '{}' \; 2> /dev/null
prepgamesdirs
}
diff --git a/games-arcade/bub-n-bros/files/bubnbros-server b/games-arcade/bub-n-bros/files/bubnbros-server
deleted file mode 100644
index e60361f89f37..000000000000
--- a/games-arcade/bub-n-bros/files/bubnbros-server
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-cd GENTOO_DIR
-exec python bb.py $@