summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2006-09-27 18:29:06 +0000
committerTristan Heaven <tristan@gentoo.org>2006-09-27 18:29:06 +0000
commit78668a804398dcdbf51485748a090efc22d8dbf9 (patch)
tree36038e95e12fdc4666293a13cc8ef714a3b9e893 /games-arcade
parentRevision bump to force an upgrade due to bug #148682. (diff)
downloadhistorical-78668a804398dcdbf51485748a090efc22d8dbf9.tar.gz
historical-78668a804398dcdbf51485748a090efc22d8dbf9.tar.bz2
historical-78668a804398dcdbf51485748a090efc22d8dbf9.zip
Move games_pkg_setup to the end of pkg_setup
Package-Manager: portage-2.1.2_pre1-r3
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/defendguin/defendguin-0.0.10.ebuild4
-rw-r--r--games-arcade/project-starfighter/files/digest-project-starfighter-1.12
-rw-r--r--games-arcade/project-starfighter/project-starfighter-1.1.ebuild4
-rw-r--r--games-arcade/pycadia/pycadia-0.5.1.ebuild4
-rw-r--r--games-arcade/supertux/supertux-0.1.3.ebuild4
5 files changed, 10 insertions, 8 deletions
diff --git a/games-arcade/defendguin/defendguin-0.0.10.ebuild b/games-arcade/defendguin/defendguin-0.0.10.ebuild
index 2128c55a3ceb..70a1b57978e1 100644
--- a/games-arcade/defendguin/defendguin-0.0.10.ebuild
+++ b/games-arcade/defendguin/defendguin-0.0.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/defendguin/defendguin-0.0.10.ebuild,v 1.7 2006/04/17 21:59:53 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/defendguin/defendguin-0.0.10.ebuild,v 1.8 2006/09/27 18:25:49 nyhm Exp $
inherit eutils games
DESCRIPTION="A clone of the arcade game Defender, but with a Linux theme"
@@ -16,10 +16,10 @@ DEPEND="media-libs/sdl-mixer
media-libs/libsdl"
pkg_setup() {
- games_pkg_setup
if ! built_with_use media-libs/sdl-mixer mikmod; then
die "You need to build media-libs/sdl-mixer with mikmod USE flag enabled!"
fi
+ games_pkg_setup
}
src_unpack() {
diff --git a/games-arcade/project-starfighter/files/digest-project-starfighter-1.1 b/games-arcade/project-starfighter/files/digest-project-starfighter-1.1
index aa30c1b45dc0..ffbddd0392d8 100644
--- a/games-arcade/project-starfighter/files/digest-project-starfighter-1.1
+++ b/games-arcade/project-starfighter/files/digest-project-starfighter-1.1
@@ -1 +1,3 @@
MD5 6a4b704dbc83c7403842b936f95ee958 project-starfighter-1.1.tar.gz 2523399
+RMD160 6cdc1e3fc4efaf56102f0e85f1ed479204a20202 project-starfighter-1.1.tar.gz 2523399
+SHA256 820d7c52fb997dca3e7b2a5f8183936474395dbae343f618540e0183a4c17186 project-starfighter-1.1.tar.gz 2523399
diff --git a/games-arcade/project-starfighter/project-starfighter-1.1.ebuild b/games-arcade/project-starfighter/project-starfighter-1.1.ebuild
index 4eff83d1d8bb..f8f1393dc085 100644
--- a/games-arcade/project-starfighter/project-starfighter-1.1.ebuild
+++ b/games-arcade/project-starfighter/project-starfighter-1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/project-starfighter/project-starfighter-1.1.ebuild,v 1.14 2006/09/26 15:10:11 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/project-starfighter/project-starfighter-1.1.ebuild,v 1.15 2006/09/27 18:27:05 nyhm Exp $
inherit eutils games
@@ -22,11 +22,11 @@ DEPEND="media-libs/libsdl
S=${WORKDIR}/${MY_P}
pkg_setup() {
- games_pkg_setup
if ! built_with_use media-libs/sdl-image gif
then
die "You need to build media-libs/sdl-image with USE=gif!"
fi
+ games_pkg_setup
}
src_unpack() {
diff --git a/games-arcade/pycadia/pycadia-0.5.1.ebuild b/games-arcade/pycadia/pycadia-0.5.1.ebuild
index e4e434bac8ac..843ac3a6924b 100644
--- a/games-arcade/pycadia/pycadia-0.5.1.ebuild
+++ b/games-arcade/pycadia/pycadia-0.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/pycadia/pycadia-0.5.1.ebuild,v 1.9 2006/04/13 20:13:39 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/pycadia/pycadia-0.5.1.ebuild,v 1.10 2006/09/27 18:29:06 nyhm Exp $
inherit games
@@ -19,7 +19,6 @@ DEPEND=">=dev-python/pygame-1.5.5
S=${WORKDIR}/${PN}
pkg_setup() {
- games_pkg_setup
# bug #101464
if has_version '<dev-python/pygtk-2.8.0-r2' ; then
if ! built_with_use dev-python/pygtk gnome ; then
@@ -27,6 +26,7 @@ pkg_setup() {
die "Please emerge dev-python/pygtk with USE=gnome"
fi
fi
+ games_pkg_setup
}
src_unpack() {
diff --git a/games-arcade/supertux/supertux-0.1.3.ebuild b/games-arcade/supertux/supertux-0.1.3.ebuild
index 2f9a0d98f381..bd36914b5d44 100644
--- a/games-arcade/supertux/supertux-0.1.3.ebuild
+++ b/games-arcade/supertux/supertux-0.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/supertux/supertux-0.1.3.ebuild,v 1.5 2006/04/13 20:16:09 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/supertux/supertux-0.1.3.ebuild,v 1.6 2006/09/27 18:28:05 nyhm Exp $
GAMES_USE_SDL="nojoystick" #bug #100372
inherit eutils games
@@ -22,10 +22,10 @@ DEPEND="${RDEPEND}
|| ( x11-libs/libXt virtual/x11 )"
pkg_setup() {
- games_pkg_setup
if ! built_with_use media-libs/sdl-mixer mikmod ; then
die "Please emerge sdl-mixer with USE=mikmod"
fi
+ games_pkg_setup
}
src_unpack() {