summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-10-16 01:11:53 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-10-16 01:11:53 +0000
commitd75d866ec5a3276f7ca6c13df1c45a9ef8f404e5 (patch)
treeeab7363bc14df62c8026e69024e79e38ed851d7b /games-roguelike/scourge
parentAdded ~sparc keyword for bug #67731. (diff)
downloadhistorical-d75d866ec5a3276f7ca6c13df1c45a9ef8f404e5.tar.gz
historical-d75d866ec5a3276f7ca6c13df1c45a9ef8f404e5.tar.bz2
historical-d75d866ec5a3276f7ca6c13df1c45a9ef8f404e5.zip
version bump (bug #66806) - ebuild submitted by Jamis Buck
Diffstat (limited to 'games-roguelike/scourge')
-rw-r--r--games-roguelike/scourge/ChangeLog7
-rw-r--r--games-roguelike/scourge/Manifest4
-rw-r--r--games-roguelike/scourge/files/digest-scourge-0.61
-rw-r--r--games-roguelike/scourge/scourge-0.6.ebuild46
4 files changed, 56 insertions, 2 deletions
diff --git a/games-roguelike/scourge/ChangeLog b/games-roguelike/scourge/ChangeLog
index 33274be364f7..595cc8269d1a 100644
--- a/games-roguelike/scourge/ChangeLog
+++ b/games-roguelike/scourge/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-roguelike/scourge
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/ChangeLog,v 1.4 2004/06/24 23:14:03 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/ChangeLog,v 1.5 2004/10/16 01:11:53 mr_bones_ Exp $
+
+*scourge-0.6 (15 Oct 2004)
+
+ 15 Oct 2004; Michael Sterrett <mr_bones_@gentoo.org> +scourge-0.6.ebuild:
+ version bump (bug #66806) - ebuild submitted by Jamis Buck
18 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> scourge-0.1.ebuild:
don't RDEPEND on sed
diff --git a/games-roguelike/scourge/Manifest b/games-roguelike/scourge/Manifest
index 83816288c076..c28c7a82a61f 100644
--- a/games-roguelike/scourge/Manifest
+++ b/games-roguelike/scourge/Manifest
@@ -1,4 +1,6 @@
MD5 caaa05ff796be8cb565101ba8a6f96ff scourge-0.1.ebuild 966
-MD5 97933186c2893596ac7ceced8527b767 ChangeLog 536
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 89b7548c4fae25bce7894aaf380cc163 ChangeLog 703
+MD5 5521340608f854f03a5714ec3b4b2c73 scourge-0.6.ebuild 1128
MD5 2feb34e8daadb3f37513752485694576 files/digest-scourge-0.1 64
+MD5 078a5fb38a1206623b65412525e7e55e files/digest-scourge-0.6 64
diff --git a/games-roguelike/scourge/files/digest-scourge-0.6 b/games-roguelike/scourge/files/digest-scourge-0.6
new file mode 100644
index 000000000000..d138a67eb91d
--- /dev/null
+++ b/games-roguelike/scourge/files/digest-scourge-0.6
@@ -0,0 +1 @@
+MD5 e70cff98dcc8026d72ad9dbfd0890ac9 scourge-0.6.tar.gz 3809155
diff --git a/games-roguelike/scourge/scourge-0.6.ebuild b/games-roguelike/scourge/scourge-0.6.ebuild
new file mode 100644
index 000000000000..0ebebbd0b8c2
--- /dev/null
+++ b/games-roguelike/scourge/scourge-0.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/scourge-0.6.ebuild,v 1.1 2004/10/16 01:11:53 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="A rogue-like adventure game to eliminate pests"
+HOMEPAGE="http://scourge.sf.net"
+SRC_URI="mirror://sourceforge/scourge/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc amd64"
+IUSE=""
+
+DEPEND="virtual/x11
+ virtual/glut
+ virtual/opengl
+ >=media-libs/libsdl-1.2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}/src"
+ sed -i \
+ -e "s:\"data/:\"${GAMES_DATADIR}/${PN}/data/:g" \
+ shapepalette.cpp text.cpp \
+ || die "sed failed"
+ find "${S}" -name .DS_Store -exec rm -f \{\} \;
+ find "${S}/data" -type f -exec chmod a-x \{\} \;
+}
+
+src_compile() {
+ egamesconf \
+ --with-data-dir="${GAMES_DATADIR}/${PN}/data" \
+ || die
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin src/scourge || die "dogamesbin failed"
+ dodir "${GAMES_DATADIR}/${PN}"
+ cp -r data/ "${D}${GAMES_DATADIR}/${PN}" || die "cp failed"
+ dodoc AUTHORS README || die "dodoc failed"
+ prepgamesdirs
+}