summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Hüttel <dilfridge@gentoo.org>2012-06-21 21:55:08 +0000
committerAndreas Hüttel <dilfridge@gentoo.org>2012-06-21 21:55:08 +0000
commit069ac1542ef075cd556dfbb8d0e420eae342dc39 (patch)
tree1dd564f7adb4f21ca4525760daf1f3d100ef29ae /kde-base/kcheckpass
parentMark stable for amd64/x86 per bug #415255 (diff)
downloadhistorical-069ac1542ef075cd556dfbb8d0e420eae342dc39.tar.gz
historical-069ac1542ef075cd556dfbb8d0e420eae342dc39.tar.bz2
historical-069ac1542ef075cd556dfbb8d0e420eae342dc39.zip
KDE 4.8.4 version bump
Package-Manager: portage-2.2.0_alpha110/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kcheckpass')
-rw-r--r--kde-base/kcheckpass/ChangeLog8
-rw-r--r--kde-base/kcheckpass/kcheckpass-4.8.4.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/kde-base/kcheckpass/ChangeLog b/kde-base/kcheckpass/ChangeLog
index 010c0c7d6b93..97bf56d6a385 100644
--- a/kde-base/kcheckpass/ChangeLog
+++ b/kde-base/kcheckpass/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kcheckpass
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.224 2012/05/24 11:38:12 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.225 2012/06/21 21:55:03 dilfridge Exp $
+
+*kcheckpass-4.8.4 (21 Jun 2012)
+
+ 21 Jun 2012; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kcheckpass-4.8.4.ebuild:
+ Version bump KDE SC 4.8.4
24 May 2012; Johannes Huber <johu@gentoo.org> -kcheckpass-4.8.1.ebuild:
Remove KDE SC 4.8.1
diff --git a/kde-base/kcheckpass/kcheckpass-4.8.4.ebuild b/kde-base/kcheckpass/kcheckpass-4.8.4.ebuild
new file mode 100644
index 000000000000..538208d73134
--- /dev/null
+++ b/kde-base/kcheckpass/kcheckpass-4.8.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-4.8.4.ebuild,v 1.1 2012/06/21 21:55:03 dilfridge Exp $
+
+EAPI=4
+
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication."
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug pam"
+
+RDEPEND="
+ pam? (
+ >=kde-base/kdebase-pam-7
+ virtual/pam
+ )
+"
+DEPEND="${RDEPEND}
+ x11-libs/libxkbfile
+"
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ use pam && epatch "${FILESDIR}/${PN}-4.4.2-no-SUID-no-GUID.patch"
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with pam)
+ )
+
+ kde4-meta_src_configure
+}