summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2010-03-30 22:09:01 +0000
committerDror Levin <spatz@gentoo.org>2010-03-30 22:09:01 +0000
commitc7727be4b0afc8770706af012e82f18d8ebbe310 (patch)
tree5159793e5568a4b70770653cf9afd9c74989ef2e /kde-base/smoke
parentold (diff)
downloadhistorical-c7727be4b0afc8770706af012e82f18d8ebbe310.tar.gz
historical-c7727be4b0afc8770706af012e82f18d8ebbe310.tar.bz2
historical-c7727be4b0afc8770706af012e82f18d8ebbe310.zip
Version bump KDE 4.4.2
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/smoke')
-rw-r--r--kde-base/smoke/ChangeLog7
-rw-r--r--kde-base/smoke/smoke-4.4.2.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/kde-base/smoke/ChangeLog b/kde-base/smoke/ChangeLog
index 9df7f21baff5..28914352c4d3 100644
--- a/kde-base/smoke/ChangeLog
+++ b/kde-base/smoke/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/smoke
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/ChangeLog,v 1.96 2010/03/26 15:15:10 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/ChangeLog,v 1.97 2010/03/30 22:05:05 spatz Exp $
+
+*smoke-4.4.2 (30 Mar 2010)
+
+ 30 Mar 2010; Dror Levin <spatz@gentoo.org> +smoke-4.4.2.ebuild:
+ Version bump
26 Mar 2010; Maciej Mrozowski <reavertm@gentoo.org> smoke-4.4.1.ebuild,
+files/smoke-4.4.1-webkit-cmake.patch, -files/smoke-phonon-fix.patch:
diff --git a/kde-base/smoke/smoke-4.4.2.ebuild b/kde-base/smoke/smoke-4.4.2.ebuild
new file mode 100644
index 000000000000..dfaec50ec899
--- /dev/null
+++ b/kde-base/smoke/smoke-4.4.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/smoke-4.4.2.ebuild,v 1.1 2010/03/30 22:05:05 spatz Exp $
+
+EAPI="3"
+
+KMNAME="kdebindings"
+WEBKIT_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="Scripting Meta Object Kompiler Engine"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="akonadi kdevplatform okular +phonon qimageblitz qtmultimedia qscintilla qwt semantic-desktop"
+
+COMMON_DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ akonadi? ( $(add_kdebase_dep kdepimlibs) )
+ kdevplatform? ( dev-util/kdevplatform:4 )
+ okular? ( $(add_kdebase_dep okular) )
+ phonon? ( >=media-sound/phonon-4.3.80[xcb] )
+ qimageblitz? ( >=kde-base/qimageblitz-0.0.4 )
+ qscintilla? ( x11-libs/qscintilla )
+ qwt? ( x11-libs/qwt:5 )
+"
+
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+KMEXTRA="generator/"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_enable akonadi)
+ $(cmake-utils_use_enable akonadi Kdepimlibs)
+ $(cmake-utils_use_enable kdevplatform KDEVPLATFORM_SMOKE)
+ $(cmake-utils_use_enable okular)
+ $(cmake-utils_use_enable phonon PHONON_SMOKE)
+ $(cmake-utils_use_enable qimageblitz QIMAGEBLITZ_SMOKE)
+ $(cmake-utils_use_enable qscintilla QSCI_SMOKE)
+ $(cmake-utils_use_enable qtmultimedia QTMULTIMEDIA_SMOKE)
+ $(cmake-utils_use_enable qwt QWT_SMOKE)
+ $(cmake-utils_use_enable semantic-desktop Nepomuk)
+ $(cmake-utils_use_enable semantic-desktop Soprano)
+ $(cmake-utils_use_enable webkit QTWEBKIT_SMOKE)
+ )
+ kde4-meta_src_configure
+}