summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-03-11 10:21:00 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-03-11 10:21:00 +0000
commit57441b5ef9773d6c3bd15fb317625946cef71579 (patch)
tree714758d79cc49e5b88181d145ff52a20a3aa15e2 /media-sound/vmpk/vmpk-0.6.0.ebuild
parentversion bump (diff)
downloadhistorical-57441b5ef9773d6c3bd15fb317625946cef71579.tar.gz
historical-57441b5ef9773d6c3bd15fb317625946cef71579.tar.bz2
historical-57441b5ef9773d6c3bd15fb317625946cef71579.zip
version bump
Signed-off-by: aballier@gentoo.org Package-Manager: portage-2.2.18/cvs/Linux x86_64 Manifest-Sign-Key: 0x160F534A
Diffstat (limited to 'media-sound/vmpk/vmpk-0.6.0.ebuild')
-rw-r--r--media-sound/vmpk/vmpk-0.6.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-sound/vmpk/vmpk-0.6.0.ebuild b/media-sound/vmpk/vmpk-0.6.0.ebuild
new file mode 100644
index 000000000000..195a4f235b86
--- /dev/null
+++ b/media-sound/vmpk/vmpk-0.6.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vmpk/vmpk-0.6.0.ebuild,v 1.1 2015/03/11 10:20:53 aballier Exp $
+
+EAPI=4
+
+inherit cmake-utils eutils
+
+DESCRIPTION="Virtual MIDI Piano Keyboard"
+HOMEPAGE="http://vmpk.sourceforge.net/"
+SRC_URI="mirror://sourceforge/vmpk/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/linguist-tools:5
+ dev-qt/qtx11extras:5
+ x11-libs/libxcb
+ media-sound/drumstick
+ dbus? ( dev-qt/qtdbus:5 )"
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_configure() {
+ local mycmakeargs=(
+ "$(cmake-utils_use_enable dbus DBUS)"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ rm -rf "${D}/usr/share/doc/packages"
+}