summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-01-26 10:36:52 +0000
committerPeter Volkov <pva@gentoo.org>2008-01-26 10:36:52 +0000
commit4b0b7303d020a5220c0df5c766cb400781d71ffd (patch)
tree72768406bc75c3be9ba85c8901d7128bb2492118 /net-analyzer/echoping/echoping-6.0.2.ebuild
parentDropped ppc-macos keyword, see you in prefix (diff)
downloadhistorical-4b0b7303d020a5220c0df5c766cb400781d71ffd.tar.gz
historical-4b0b7303d020a5220c0df5c766cb400781d71ffd.tar.bz2
historical-4b0b7303d020a5220c0df5c766cb400781d71ffd.zip
Do not die if ssl and gnutls are enabled, better chose gnutls, thank Paul Tobias <tobias.pal AT gmail.com> for patch, bug #141782.
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'net-analyzer/echoping/echoping-6.0.2.ebuild')
-rw-r--r--net-analyzer/echoping/echoping-6.0.2.ebuild26
1 files changed, 14 insertions, 12 deletions
diff --git a/net-analyzer/echoping/echoping-6.0.2.ebuild b/net-analyzer/echoping/echoping-6.0.2.ebuild
index 77c127cd9f14..2b3c34d7420a 100644
--- a/net-analyzer/echoping/echoping-6.0.2.ebuild
+++ b/net-analyzer/echoping/echoping-6.0.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/echoping/echoping-6.0.2.ebuild,v 1.2 2007/09/06 16:25:35 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/echoping/echoping-6.0.2.ebuild,v 1.3 2008/01/26 10:36:52 pva Exp $
inherit eutils
@@ -19,27 +19,29 @@ DEPEND="gnutls? ( >=net-libs/gnutls-1.0.17 )
postgres? ( dev-db/postgresql )
ldap? ( net-nds/openldap )"
-pkg_setup() {
- # bug 141782 - conflicting USE flags - ssl and gnutls
- if use ssl && use gnutls ; then
- eerror "You cannot emerge net-analyzer/echoping with both"
- eerror "ssl and gnutls USE flags set. Please choose one."
- die "echoping cannot use both ssl and gnutls at once"
+src_compile() {
+ local my_ssl_conf
+ if use gnutls; then
+ if use ssl; then
+ ewarn "You've enabled both ssl and gnutls USE flags but ${PN} could"
+ ewarn "not be built with both, see bug #141782. Using gnutls only."
+ fi
+ my_ssl_conf="${myconf} $(use_with gnutls)"
+ elif use ssl; then
+ my_ssl_conf="${myconf} $(use_with ssl)"
fi
-}
-src_compile() {
econf \
--config-cache \
--disable-ttcp \
- $(use_with gnutls) \
+ ${my_ssl_conf} \
$(use_enable http) \
$(use_enable icp) \
$(use_with idn libidn) \
$(use_enable smtp) \
$(use_enable tos) \
$(use_enable priority) \
- $(use_with ssl) || die "econf failed"
+ || die "econf failed"
emake || die "emake failed"
}