summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2008-04-25 10:45:14 +0000
committerWolfram Schlich <wschlich@gentoo.org>2008-04-25 10:45:14 +0000
commit8d976619e0f140af7fa26d5fdcbf60fbf3093cb9 (patch)
tree161da0932615b3ad8c8b577e696bd110bd7a4d81 /net-analyzer/portbunny
parentversion bump (diff)
downloadhistorical-8d976619e0f140af7fa26d5fdcbf60fbf3093cb9.tar.gz
historical-8d976619e0f140af7fa26d5fdcbf60fbf3093cb9.tar.bz2
historical-8d976619e0f140af7fa26d5fdcbf60fbf3093cb9.zip
initial import
Package-Manager: portage-2.1.5_rc4
Diffstat (limited to 'net-analyzer/portbunny')
-rw-r--r--net-analyzer/portbunny/ChangeLog11
-rw-r--r--net-analyzer/portbunny/Manifest6
-rw-r--r--net-analyzer/portbunny/metadata.xml10
-rw-r--r--net-analyzer/portbunny/portbunny-1.0.ebuild57
-rw-r--r--net-analyzer/portbunny/portbunny-1.0_p20080423.ebuild57
5 files changed, 141 insertions, 0 deletions
diff --git a/net-analyzer/portbunny/ChangeLog b/net-analyzer/portbunny/ChangeLog
new file mode 100644
index 000000000000..a75d4e2c97a8
--- /dev/null
+++ b/net-analyzer/portbunny/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-analyzer/portbunny
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/portbunny/ChangeLog,v 1.1 2008/04/25 10:45:14 wschlich Exp $
+
+*portbunny-1.0_p20080423 (25 Apr 2008)
+*portbunny-1.0 (25 Apr 2008)
+
+ 25 Apr 2008; Wolfram Schlich <wschlich@gentoo.org> +metadata.xml,
+ +portbunny-1.0.ebuild, +portbunny-1.0_p20080423.ebuild:
+ initial import
+
diff --git a/net-analyzer/portbunny/Manifest b/net-analyzer/portbunny/Manifest
new file mode 100644
index 000000000000..bcad00b1ab17
--- /dev/null
+++ b/net-analyzer/portbunny/Manifest
@@ -0,0 +1,6 @@
+DIST PortBunny-1.0.tar.gz 213855 RMD160 5b5b54733bccc2860515a952097c1f9351a47dd1 SHA1 532f27fa29c3d24677cc6961159ed22531b83358 SHA256 cfe1e5b84b66577299d920dd6f1a1637e948dd4fb2a75ab5265de273ffb6287c
+DIST PortBunny230408.tar.gz 224753 RMD160 b7d1237dce113810c2740d9cc62a61a0a7c960f4 SHA1 68a52f806f6513ee05ebabd77eb97cd957032e67 SHA256 ace967834ffe36a0e2f073a46b3a81b48671cc78e2d2cca6eb2ca6a63d05ead3
+EBUILD portbunny-1.0.ebuild 1557 RMD160 35ae0691268fc37d2536097d5f3d26b181092303 SHA1 8dc3110acde461522909508bea6ea9a5f098a338 SHA256 917acacbc493c3c1651b356a0939a26753417550fefc5618fe9dbd9bcd639a66
+EBUILD portbunny-1.0_p20080423.ebuild 1567 RMD160 63a0b390a2920235b6f8a36faed6df2f783ef51c SHA1 48960d5584d6121005ad22dce10d8278462ae0d6 SHA256 4a58d166c7fba545ac62807f8810e9eca9c9015fa9ce4630008f810d8e8a8af9
+MISC ChangeLog 432 RMD160 d2a6f451df1ddfd9bc33424797e6401e0e3b2d81 SHA1 3e7ed34279046d97ff27b2a5b92c6dd4158653cc SHA256 1409c2d126eff87293e7e8b21c947ba9db211ffc5a688a8f93f95885bf89560f
+MISC metadata.xml 300 RMD160 3b9c1cd628f9d7ac94b68543ec737d5c2381a47e SHA1 33c5efd31a8aa789118535b921e211ffb5023ac3 SHA256 bc07a9aecce5770d1ace9af0a6c6af8ff6c7b16eb5e7947a1b178d1970855e43
diff --git a/net-analyzer/portbunny/metadata.xml b/net-analyzer/portbunny/metadata.xml
new file mode 100644
index 000000000000..a7162e9b7104
--- /dev/null
+++ b/net-analyzer/portbunny/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>wschlich@gentoo.org</email>
+ <name>Wolfram Schlich</name>
+ <description>Primary maintainer</description>
+</maintainer>
+</pkgmetadata>
diff --git a/net-analyzer/portbunny/portbunny-1.0.ebuild b/net-analyzer/portbunny/portbunny-1.0.ebuild
new file mode 100644
index 000000000000..860490db6e73
--- /dev/null
+++ b/net-analyzer/portbunny/portbunny-1.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/portbunny/portbunny-1.0.ebuild,v 1.1 2008/04/25 10:45:14 wschlich Exp $
+
+inherit eutils linux-mod
+
+MY_PV_SNAP=${PV##*_p}
+if [[ ${MY_PV_SNAP} != ${PV} ]]; then
+ MY_PV=${MY_PV_SNAP:6:2}${MY_PV_SNAP:4:2}${MY_PV_SNAP:2:2}
+ MY_P=PortBunny${MY_PV}
+ S="${WORKDIR}"/${MY_P}-dev
+else
+ MY_P=PortBunny-${PV}
+ S="${WORKDIR}"/${MY_P}
+fi
+
+MODULE_NAMES="portbunny(kernel:)"
+BUILD_TARGETS="all"
+
+DESCRIPTION="A kernel based highspeed TCP SYN port scanner"
+HOMEPAGE="http://recurity-labs.com/portbunny/"
+SRC_URI="http://recurity-labs.com/portbunny/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-lang/python"
+
+src_install() {
+ insinto /usr/share/portbunny
+ doins UI/share/portbunny/*
+ dosed "s:^\(ETC_SERVICES\)[[:space:]]\+=.*:\1 = '/usr/share/portbunny/services':g" \
+ /usr/share/portbunny/PBunnyServices.py
+ dobin UI/bin/portbunny.py
+ dosym portbunny.py /usr/bin/portbunny
+ dosed "s:^\(PBUNNY_SHARE\)[[:space:]]\+=.*:\1 = '/usr/share/portbunny/':g" \
+ /usr/bin/portbunny.py
+ dosed "s:^\(PBUNNY_SHARE2\)[[:space:]]\+=.*:\1 = '/usr/share/portbunny/':g" \
+ /usr/bin/portbunny.py
+
+ linux-mod_src_install
+}
+
+pkg_postinst() {
+ einfo
+ einfo "See http://recurity-labs.com/portbunny/README.pdf"
+ einfo
+ ewarn
+ ewarn "WARNING"
+ ewarn "WARNING: this software may HARM the stability of your system!"
+ ewarn "WARNING: do NOT use this on production machines!"
+ ewarn "WARNING"
+ ewarn
+ ebeep 10
+}
diff --git a/net-analyzer/portbunny/portbunny-1.0_p20080423.ebuild b/net-analyzer/portbunny/portbunny-1.0_p20080423.ebuild
new file mode 100644
index 000000000000..042bbf1487bc
--- /dev/null
+++ b/net-analyzer/portbunny/portbunny-1.0_p20080423.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/portbunny/portbunny-1.0_p20080423.ebuild,v 1.1 2008/04/25 10:45:14 wschlich Exp $
+
+inherit eutils linux-mod
+
+MY_PV_SNAP=${PV##*_p}
+if [[ ${MY_PV_SNAP} != ${PV} ]]; then
+ MY_PV=${MY_PV_SNAP:6:2}${MY_PV_SNAP:4:2}${MY_PV_SNAP:2:2}
+ MY_P=PortBunny${MY_PV}
+ S="${WORKDIR}"/${MY_P}-dev
+else
+ MY_P=PortBunny-${PV}
+ S="${WORKDIR}"/${MY_P}
+fi
+
+MODULE_NAMES="portbunny(kernel:)"
+BUILD_TARGETS="all"
+
+DESCRIPTION="A kernel based highspeed TCP SYN port scanner"
+HOMEPAGE="http://recurity-labs.com/portbunny/"
+SRC_URI="http://recurity-labs.com/portbunny/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-lang/python"
+
+src_install() {
+ insinto /usr/share/portbunny
+ doins UI/share/portbunny/*
+ dosed "s:^\(ETC_SERVICES\)[[:space:]]\+=.*:\1 = '/usr/share/portbunny/services':g" \
+ /usr/share/portbunny/PBunnyServices.py
+ dobin UI/bin/portbunny.py
+ dosym portbunny.py /usr/bin/portbunny
+ dosed "s:^\(PBUNNY_SHARE\)[[:space:]]\+=.*:\1 = '/usr/share/portbunny/':g" \
+ /usr/bin/portbunny.py
+ dosed "s:^\(PBUNNY_SHARE2\)[[:space:]]\+=.*:\1 = '/usr/share/portbunny/':g" \
+ /usr/bin/portbunny.py
+
+ linux-mod_src_install
+}
+
+pkg_postinst() {
+ einfo
+ einfo "See http://recurity-labs.com/portbunny/README.pdf"
+ einfo
+ ewarn
+ ewarn "WARNING"
+ ewarn "WARNING: this software may HARM the stability of your system!"
+ ewarn "WARNING: do NOT use this on production machines!"
+ ewarn "WARNING"
+ ewarn
+ ebeep 10
+}