summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-02-19 11:05:37 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-02-19 11:05:37 +0000
commitd73d5ebf697b3e8fc183e528ba2c03fb2f6dc8be (patch)
tree43662d3e869236125d1f5086dbe6c39ee3531b9e /net-dns/openresolv/openresolv-2.0.1.ebuild
parentAdd patch to fix ia64 build failure from the openssl mailing list, thanks to ... (diff)
downloadhistorical-d73d5ebf697b3e8fc183e528ba2c03fb2f6dc8be.tar.gz
historical-d73d5ebf697b3e8fc183e528ba2c03fb2f6dc8be.tar.bz2
historical-d73d5ebf697b3e8fc183e528ba2c03fb2f6dc8be.zip
Version bump
Package-Manager: portage-2.1.6.4/cvs/Linux 2.6.27-gentoo-r8 ia64
Diffstat (limited to 'net-dns/openresolv/openresolv-2.0.1.ebuild')
-rw-r--r--net-dns/openresolv/openresolv-2.0.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-dns/openresolv/openresolv-2.0.1.ebuild b/net-dns/openresolv/openresolv-2.0.1.ebuild
new file mode 100644
index 000000000000..c05dd6769d7f
--- /dev/null
+++ b/net-dns/openresolv/openresolv-2.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/openresolv/openresolv-2.0.1.ebuild,v 1.1 2009/02/19 11:05:37 armin76 Exp $
+
+inherit eutils
+
+DESCRIPTION="A framework for managing DNS information"
+HOMEPAGE="http://roy.marples.name/projects/openresolv"
+SRC_URI="http://roy.marples.name/downloads/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="!net-dns/resolvconf-gentoo
+ !<net-dns/dnsmasq-2.40-r1"
+RDEPEND=""
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Failed to install"
+}
+
+pkg_config() {
+ if [ "${ROOT}" != "/" ]; then
+ eerror "We cannot configure unless \$ROOT=/"
+ return 1
+ fi
+
+ if [ -n "$(resolvconf -l)" ]; then
+ einfo "${PN} already has DNS information"
+ else
+ ebegin "Copying /etc/resolv.conf to resolvconf -a dummy"
+ resolvconf -a dummy </etc/resolv.conf
+ eend $? || return $?
+ einfo "The dummy interface will disappear when you next reboot"
+ fi
+}