summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-06-19 23:04:36 +0000
committerMike Frysinger <vapier@gentoo.org>2011-06-19 23:04:36 +0000
commit70768550c39b43a88ddb362534fbe7b9af0780c0 (patch)
tree74c423e710190a2bcbc321987db6c25c6ec354c8 /net-fs
parentupstream went away so update to other values for homepage and src_uri (bug #3... (diff)
downloadhistorical-70768550c39b43a88ddb362534fbe7b9af0780c0.tar.gz
historical-70768550c39b43a88ddb362534fbe7b9af0780c0.tar.bz2
historical-70768550c39b43a88ddb362534fbe7b9af0780c0.zip
Remove shortcuts that result in silent errors #372297 by Sebastian Pipping.
Package-Manager: portage-2.2.0_alpha41/cvs/Linux x86_64
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/nfs-utils/ChangeLog5
-rw-r--r--net-fs/nfs-utils/files/rpc.pipefs.initd25
2 files changed, 17 insertions, 13 deletions
diff --git a/net-fs/nfs-utils/ChangeLog b/net-fs/nfs-utils/ChangeLog
index a67fea455139..e652b37de081 100644
--- a/net-fs/nfs-utils/ChangeLog
+++ b/net-fs/nfs-utils/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-fs/nfs-utils
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/ChangeLog,v 1.182 2011/05/29 00:34:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/ChangeLog,v 1.183 2011/06/19 23:04:36 vapier Exp $
+
+ 19 Jun 2011; Mike Frysinger <vapier@gentoo.org> files/rpc.pipefs.initd:
+ Remove shortcuts that result in silent errors #372297 by Sebastian Pipping.
29 May 2011; Mike Frysinger <vapier@gentoo.org> nfs-utils-1.2.3-r1.ebuild:
Make sure /var/lib/nfs exists before copying into it #368505 by William
diff --git a/net-fs/nfs-utils/files/rpc.pipefs.initd b/net-fs/nfs-utils/files/rpc.pipefs.initd
index 701ac77892b7..08467eed1ac0 100644
--- a/net-fs/nfs-utils/files/rpc.pipefs.initd
+++ b/net-fs/nfs-utils/files/rpc.pipefs.initd
@@ -1,24 +1,25 @@
#!/sbin/runscript
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/files/rpc.pipefs.initd,v 1.1 2008/10/26 09:02:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/files/rpc.pipefs.initd,v 1.2 2011/06/19 23:04:36 vapier Exp $
mount_pipefs() {
+ local fstype=rpc_pipefs mntpoint=/var/lib/nfs/rpc_pipefs
+
+ # if things are already mounted, nothing to do
+ mountinfo -q ${mntpoint} && return 0
+
# if rpc_pipefs is not available, try to load sunrpc for it #219566
- grep -qs rpc_pipefs /proc/filesystems || modprobe -q sunrpc
- # if still not available, let's bail
- grep -qs rpc_pipefs /proc/filesystems || return 1
+ grep -qs ${fstype} /proc/filesystems || modprobe -q sunrpc
+ # if still not available, the `mount` will issue an error for the user
# now just do it for kicks
- mkdir -p /var/lib/nfs/rpc_pipefs
- mount -t rpc_pipefs rpc_pipefs /var/lib/nfs/rpc_pipefs
+ mkdir -p ${mntpoint}
+ mount -t ${fstype} ${fstype} ${mntpoint}
}
start() {
- # if things are already mounted, let's just return
- grep -qs "rpc_pipefs /var/lib/nfs/rpc_pipefs" /proc/mounts && return 0
-
- ebegin "Mounting RPC pipefs"
+ ebegin "Setting up RPC pipefs"
mount_pipefs
- eend $?
+ eend $? "make sure you have NFS/SUNRPC enabled in your kernel"
}