summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2004-03-14 12:08:56 +0000
committerHeinrich Wendel <lanius@gentoo.org>2004-03-14 12:08:56 +0000
commit6766d73ac90daea142d24145b8ce2f5b6710fd32 (patch)
tree0fe1813c0733bbda6082cc7bcc44d01ade8ff0ea /net-im/licq/files
parentdon't try to assign to A; header fix (diff)
downloadhistorical-6766d73ac90daea142d24145b8ce2f5b6710fd32.tar.gz
historical-6766d73ac90daea142d24145b8ce2f5b6710fd32.tar.bz2
historical-6766d73ac90daea142d24145b8ce2f5b6710fd32.zip
compile with nptl, bug #44126
Diffstat (limited to 'net-im/licq/files')
-rw-r--r--net-im/licq/files/1.2.7-nptl.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-im/licq/files/1.2.7-nptl.patch b/net-im/licq/files/1.2.7-nptl.patch
new file mode 100644
index 000000000000..0308b33bde31
--- /dev/null
+++ b/net-im/licq/files/1.2.7-nptl.patch
@@ -0,0 +1,34 @@
+Index: configure.in
+===================================================================
+RCS file: /cvsroot/licq/licq/configure.in,v
+retrieving revision 1.63
+diff -u -d -p -r1.63 configure.in
+--- configure.in 2 Jul 2003 04:44:47 -0000 1.63
++++ configure.in 1 Jan 2004 01:46:12 -0000
+@@ -142,6 +142,8 @@ dlopen(NULL, RTLD_NOW)
+
+ AC_CHECK_FUNCS(inet_addr inet_aton mktime select strdup strerror hstrerror readdir_r)
+
++AC_CHECK_FUNC(pthread_kill_other_threads_np,[AC_DEFINE([HAVE_PTHREAD_KILL_OTHER_THREADS_NP],
++[], [we are not using NTPL])])
+ AC_CHECK_SOCKS5
+ LICQ_CHECK_OPENSSL
+
+Index: src/sighandler.c
+===================================================================
+RCS file: /cvsroot/licq/licq/src/sighandler.c,v
+retrieving revision 1.5
+diff -u -d -p -r1.5 sighandler.c
+--- src/sighandler.c 16 Jun 2003 17:09:46 -0000 1.5
++++ src/sighandler.c 1 Jan 2004 01:46:12 -0000
+@@ -83,7 +83,10 @@ void licq_handle_sigsegv(int s)
+ fprintf(stderr, "%s\n", res[0]);*/
+ }
+ fprintf(stderr, "Attempting to generate core file.\n");
++
++ #ifdef HAVE_PTHREAD_KILL_OTHER_THREADS_NP
+ pthread_kill_other_threads_np();
++ #endif
+ #endif
+
+ abort();