summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Farina <zerochaos@gentoo.org>2013-07-27 04:53:02 +0000
committerRichard Farina <zerochaos@gentoo.org>2013-07-27 04:53:02 +0000
commit2f24f7226e128ab867f2a2cfaff79394d0fdf2cd (patch)
tree055bd0a97239431bef89de10b3bd654a6f585848 /net-libs/libhackrf/libhackrf-2013.07.1.ebuild
parentVersion bump and start of the Gentoo patchset. (diff)
downloadhistorical-2f24f7226e128ab867f2a2cfaff79394d0fdf2cd.tar.gz
historical-2f24f7226e128ab867f2a2cfaff79394d0fdf2cd.tar.bz2
historical-2f24f7226e128ab867f2a2cfaff79394d0fdf2cd.zip
version bump
Package-Manager: portage-2.1.12.2/cvs/Linux x86_64 Manifest-Sign-Key: 0xDD11F94A
Diffstat (limited to 'net-libs/libhackrf/libhackrf-2013.07.1.ebuild')
-rw-r--r--net-libs/libhackrf/libhackrf-2013.07.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-libs/libhackrf/libhackrf-2013.07.1.ebuild b/net-libs/libhackrf/libhackrf-2013.07.1.ebuild
new file mode 100644
index 000000000000..0d56eb3795f5
--- /dev/null
+++ b/net-libs/libhackrf/libhackrf-2013.07.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libhackrf/libhackrf-2013.07.1.ebuild,v 1.1 2013/07/27 04:52:57 zerochaos Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="library for communicating with HackRF SDR platform"
+HOMEPAGE="http://greatscottgadgets.com/hackrf/"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/mossmann/hackrf.git"
+ inherit git-2
+ KEYWORDS=""
+ EGIT_SOURCEDIR="${WORKDIR}/hackrf"
+ S="${WORKDIR}/hackrf/host/libhackrf"
+else
+ S="${WORKDIR}/hackrf-${PV}/host/libhackrf"
+ SRC_URI="mirror://sourceforge/hackrf/hackrf-${PV}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~ppc ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE=""
+
+DEPEND="virtual/libusb:1"
+RDEPEND="${DEPEND}"