summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2012-03-11 23:56:11 +0000
committerJoshua Kinard <kumba@gentoo.org>2012-03-11 23:56:11 +0000
commit4fe293aae67dd72b27079844428885bfe39cbb95 (patch)
tree80c29dc8f23b8735f7ba43e53a0d34e0d31cab04 /net-misc/spread/spread-4.1.0.ebuild
parentVersion bump, make minor changes to pkg-config file bug #407743 (diff)
downloadhistorical-4fe293aae67dd72b27079844428885bfe39cbb95.tar.gz
historical-4fe293aae67dd72b27079844428885bfe39cbb95.tar.bz2
historical-4fe293aae67dd72b27079844428885bfe39cbb95.zip
Update the ebuilds to EAPI 4 and mark both versions stable. They've been around for a long time with no reported issues.
Package-Manager: portage-2.1.10.45/cvs/Linux x86_64
Diffstat (limited to 'net-misc/spread/spread-4.1.0.ebuild')
-rw-r--r--net-misc/spread/spread-4.1.0.ebuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/net-misc/spread/spread-4.1.0.ebuild b/net-misc/spread/spread-4.1.0.ebuild
index e2aca6cfe2bd..37ad040e2a16 100644
--- a/net-misc/spread/spread-4.1.0.ebuild
+++ b/net-misc/spread/spread-4.1.0.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/spread/spread-4.1.0.ebuild,v 1.1 2011/09/05 07:05:23 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/spread/spread-4.1.0.ebuild,v 1.2 2012/03/11 23:56:11 kumba Exp $
+EAPI=4
inherit eutils
MY_PN="spread-src"
@@ -12,7 +13,7 @@ SRC_URI="mirror://gentoo/${MY_PN}-${PV}.tar.gz"
LICENSE="Spread-1.0"
SLOT="0"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="x86 amd64"
IUSE=""
DEPEND=""
@@ -25,17 +26,13 @@ pkg_setup() {
enewgroup spread
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
# don't strip binaries
sed -i -e 's/0755 -s/0755/g' daemon/Makefile.in examples/Makefile.in
}
src_install() {
- emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}" -j1 install \
- || die "emake install failed"
- newinitd "${FILESDIR}"/spread.init.d spread || die "newinitd failed"
- dodir /var/run/spread || die "dodir failed"
+ emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}" install
+ newinitd "${FILESDIR}"/spread.init.d spread
+ dodir /var/run/spread
}