summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-29 02:55:44 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-29 02:55:44 +0000
commit8d5e070a0caaf2a602ade903e61eb5b1069831aa (patch)
treedf25c8a74cb04009d510fa4b4d05a5707c0dbc07 /net-misc/wget
parentVersion bumped. (diff)
downloadhistorical-8d5e070a0caaf2a602ade903e61eb5b1069831aa.tar.gz
historical-8d5e070a0caaf2a602ade903e61eb5b1069831aa.tar.bz2
historical-8d5e070a0caaf2a602ade903e61eb5b1069831aa.zip
cleanup and fix autotool stuff
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'net-misc/wget')
-rw-r--r--net-misc/wget/Manifest2
-rw-r--r--net-misc/wget/wget-1.9.1-r5.ebuild48
2 files changed, 19 insertions, 31 deletions
diff --git a/net-misc/wget/Manifest b/net-misc/wget/Manifest
index f5623f2fd936..f15e1abf9483 100644
--- a/net-misc/wget/Manifest
+++ b/net-misc/wget/Manifest
@@ -1,6 +1,6 @@
MD5 79557a142c0f0736210b6378c4c0937c ChangeLog 11294
MD5 d8da3021a3e635af9c4511b2a55b5633 metadata.xml 343
-MD5 d0f952e0bb6591c2840a982b1eed03d9 wget-1.9.1-r5.ebuild 1664
+MD5 267f40fc9feee7f965f5528f6fbfa13e wget-1.9.1-r5.ebuild 1689
MD5 a0a0a49fd392c3a858b70242aa3f7268 wget-1.9.1-r3.ebuild 1561
MD5 69f37da4a3708c5a2221ad21a5b25d74 files/digest-wget-1.9.1-r5 136
MD5 94ce8e0557c28ef33d5814ab3dd34980 files/digest-wget-1.9.1-r3 135
diff --git a/net-misc/wget/wget-1.9.1-r5.ebuild b/net-misc/wget/wget-1.9.1-r5.ebuild
index a55852e8df53..33a47bfbc16c 100644
--- a/net-misc/wget/wget-1.9.1-r5.ebuild
+++ b/net-misc/wget/wget-1.9.1-r5.ebuild
@@ -1,10 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.9.1-r5.ebuild,v 1.10 2005/05/21 18:47:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.9.1-r5.ebuild,v 1.11 2005/05/29 02:55:44 vapier Exp $
-inherit gnuconfig eutils flag-o-matic
-
-IUSE="build debug ipv6 nls socks5 ssl static"
+inherit eutils flag-o-matic
PATCHVER=0.3
DESCRIPTION="Network utility to retrieve files from the WWW"
@@ -16,31 +14,27 @@ SRC_URI="mirror://gnu/wget/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ~ppc-macos ppc64 s390 sh sparc x86"
+IUSE="build debug ipv6 nls socks5 ssl static"
RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
socks5? ( net-proxy/dante )"
-
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )
sys-devel/autoconf"
-
-PATCHDIR="${WORKDIR}/patches"
-
src_unpack() {
- unpack ${A} ; cd ${S}
- export EPATCH_SUFFIX="patch"
- epatch ${PATCHDIR}/gentoo
- epatch ${PATCHDIR}/debian
- epatch ${PATCHDIR}/mandrake
+ unpack ${A}
+ cd "${S}"
+ local PATCHDIR=${WORKDIR}/patches
+ EPATCH_SUFFIX="patch"
+ EPATCH_MULTI_MSG="Applying Gentoo patches ..." epatch "${PATCHDIR}"/gentoo
+ EPATCH_MULTI_MSG="Applying Debian patches ..." epatch "${PATCHDIR}"/debian
+ EPATCH_MULTI_MSG="Applying Mandrake patches ..." epatch "${PATCHDIR}"/mandrake
+ autoconf || die "autoconf failed"
}
src_compile() {
- # Make wget use up-to-date configure scripts
- gnuconfig_update
-
- use ssl && append-flags -I/usr/include/openssl
-
+ use static && append-ldflags -static
econf \
--sysconfdir=/etc/wget \
$(use_with ssl) $(use_enable ssl opie) $(use_enable ssl digest) \
@@ -49,22 +43,16 @@ src_compile() {
$(use_enable debug) \
$(use_with socks5 socks) \
|| die
-
- if use static; then
- emake LDFLAGS="--static" || die
- else
- emake || die
- fi
+ emake || die
}
src_install() {
- if use build; then
- insinto /usr
- dobin ${S}/src/wget
- return
+ if use build ; then
+ dobin "${S}"/src/wget || die "dobin"
+ return 0
fi
- make DESTDIR=${D} install || die
- dodoc AUTHORS COPYING ChangeLog MACHINES MAILING-LIST NEWS README TODO
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog MACHINES MAILING-LIST NEWS README TODO
dodoc doc/sample.wgetrc
}