summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-11-26 02:57:25 +0000
committerNick Hadaway <raker@gentoo.org>2002-11-26 02:57:25 +0000
commit09c2e7922bc90dac8fa0b2a376cc5b4db9c1f56b (patch)
tree9438072a7624b8bdef2187d585d79b85a1948581 /net-nds
parentPixmap buttons are now installed as part of latest Openbox devel release. Del... (diff)
downloadhistorical-09c2e7922bc90dac8fa0b2a376cc5b4db9c1f56b.tar.gz
historical-09c2e7922bc90dac8fa0b2a376cc5b4db9c1f56b.tar.bz2
historical-09c2e7922bc90dac8fa0b2a376cc5b4db9c1f56b.zip
New ebuild. Depends on db4 so all arches marked -.
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/openldap/ChangeLog10
-rw-r--r--net-nds/openldap/files/digest-openldap-2.1.81
-rw-r--r--net-nds/openldap/openldap-2.1.8.ebuild110
3 files changed, 120 insertions, 1 deletions
diff --git a/net-nds/openldap/ChangeLog b/net-nds/openldap/ChangeLog
index f872948e65ad..98d33cee70a3 100644
--- a/net-nds/openldap/ChangeLog
+++ b/net-nds/openldap/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-nds/openldap
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/ChangeLog,v 1.13 2002/10/11 20:51:36 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/ChangeLog,v 1.14 2002/11/26 02:57:25 raker Exp $
+
+openldap-2.1.8 (25 Nov 2002)
+
+ 25 Nov 2002; Nick Hadaway <raker@gentoo.org> openldap-2.1.8.ebuilod,
+ files/digest-openldap-2.1.8 :
+ New ebuild of openldap. Lots of configure updates. Needs lots of
+ testing. The ebuild depends on db4 so all arches are marked - until
+ db4 is marked unstable for testing.
*openldap-2.0.25-r3 (21 Sept 2002)
diff --git a/net-nds/openldap/files/digest-openldap-2.1.8 b/net-nds/openldap/files/digest-openldap-2.1.8
new file mode 100644
index 000000000000..bedec5837253
--- /dev/null
+++ b/net-nds/openldap/files/digest-openldap-2.1.8
@@ -0,0 +1 @@
+MD5 41773bf61d9eec64e223a1d9f2413f0c openldap-2.1.8.tgz 2040875
diff --git a/net-nds/openldap/openldap-2.1.8.ebuild b/net-nds/openldap/openldap-2.1.8.ebuild
new file mode 100644
index 000000000000..ca1fbdc63765
--- /dev/null
+++ b/net-nds/openldap/openldap-2.1.8.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.1.8.ebuild,v 1.1 2002/11/26 02:57:25 raker Exp $
+
+IUSE="ssl tcpd readline ipv6 berkdb gdbm ldap sasl kerberos"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="LDAP suite of application and development tools"
+SRC_URI="ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/${P}.tgz"
+HOMEPAGE="http://www.OpenLDAP.org/"
+
+SLOT="0"
+KEYWORDS="-x86 -ppc"
+LICENSE="OPENLDAP"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/readline-4.2a
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ readline? ( >=sys-libs/readline-4.1 )
+ berkdb? ( >=sys-libs/db-4.0.14 )
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ sasl? ( >=dev-libs/cyrus-sasl-2.1.7-r3 )
+ kerberos? ( >=app-crypt/krb5-1.2.6 )"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+src_compile() {
+ local myconf
+
+ if [ -n "$DEBUG" ]; then
+ myconf="--enable-debug"
+ else
+ myconf="--disable-debug"
+ fi
+
+ use sasl \
+ && myconf="${myconf} --with-cyrus-sasl --enable-spasswd" \
+ || myconf="${myconf} --without-cyrus-sasl --disable-spasswd"
+
+ use kerberos \
+ && myconf="${myconf} --with-kerberos --enable-kpasswd" \
+ || myconf="${myconf} --without-kerberos --disable-kpasswd"
+
+ use readline \
+ && myconf="${myconf} --with-readline" \
+ || myconf="${myconf} --without-readline"
+
+ use ssl \
+ && myconf="${myconf} --with-tls" \
+ || myconf="${myconf} --without-tls"
+
+ use tcpd \
+ && myconf="${myconf} --enable-wrappers" \
+ || myconf="${myconf} --disable-wrappers"
+
+ if use berkdb; then
+ myconf="${myconf} --enable-ldbm --with-ldbm-api=berkeley"
+ elif use gdbm; then
+ myconf="${myconf} --enable-ldbm --with-ldbm-api=gdbm"
+ elif use ldap-none; then
+ myconf="${myconf} --disable-ldbm"
+ else
+ myconf="${myconf} --enable-ldbm --with-ldbm-api=auto"
+ fi
+
+ use ipv6 && myconf="${myconf} --enable-ipv6" \
+ || myconf="${myconf} --disable-ipv6"
+
+ econf \
+ --libexecdir=/usr/lib/openldap \
+ --enable-crypt \
+ --enable-dynamic \
+ --enable-lmpasswd \
+ --enable-modules \
+ --enable-phonetic \
+ --enable-rewrite \
+ --enable-slp \
+ --enable-meta \
+ --enable-monitor \
+ --enable-passwd \
+ --enable-perl \
+ --enable-shell \
+ --enable-sql \
+ --enable-slurpd \
+ ${myconf} || die "configure failed"
+
+ make depend || die "make depend failed"
+
+ make || die "make failed"
+
+ cd tests ; make || die "make tests failed"
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die "make install failed"
+
+ dodoc ANNOUNCEMENT CHANGES COPYRIGHT README LICENSE
+ docinto rfc ; dodoc doc/rfc/*.txt
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/slapd.rc6 slapd
+ newexe ${FILESDIR}/slurpd.rc6 slurpd
+
+}