summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2007-07-12 17:16:41 +0000
committerJim Ramsay <lack@gentoo.org>2007-07-12 17:16:41 +0000
commita4c95833eaf3e830ce61137571cf96f31e80bedf (patch)
treea1731bd5ab6b474b70b4f6ba110fe5230df147af /rox-extra/musicbox/musicbox-027-r2.ebuild
parentStable for HPPA (bug #184029). (diff)
downloadhistorical-a4c95833eaf3e830ce61137571cf96f31e80bedf.tar.gz
historical-a4c95833eaf3e830ce61137571cf96f31e80bedf.tar.bz2
historical-a4c95833eaf3e830ce61137571cf96f31e80bedf.zip
Removing flac USE flag, until we become compatible with flac-1.1.3 (bug 181864)
Package-Manager: portage-2.1.3_rc4
Diffstat (limited to 'rox-extra/musicbox/musicbox-027-r2.ebuild')
-rw-r--r--rox-extra/musicbox/musicbox-027-r2.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/rox-extra/musicbox/musicbox-027-r2.ebuild b/rox-extra/musicbox/musicbox-027-r2.ebuild
new file mode 100644
index 000000000000..4892eb2ff373
--- /dev/null
+++ b/rox-extra/musicbox/musicbox-027-r2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/rox-extra/musicbox/musicbox-027-r2.ebuild,v 1.1 2007/07/12 17:16:41 lack Exp $
+
+ROX_LIB_VER=2.0.0
+inherit rox eutils
+
+DESCRIPTION="MusicBox - an MP3/OGG Player for the ROX Desktop"
+HOMEPAGE="http://www.hayber.us/rox/MusicBox/"
+SRC_URI="http://www.hayber.us/rox/musicbox/MusicBox-027.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="mp3 vorbis alsa"
+
+# NOTE: flac support is removed because it requires 1.1.2, and 1.1.3 is now
+# being unmasked. See bug 181864 for more info.
+
+DEPEND="
+ >=dev-python/pyao-0.81
+ alsa? ( >=dev-python/pyalsaaudio-0.2 )
+ mp3? (
+ >=dev-python/pymad-0.4.1
+ >=dev-python/pyid3lib-0.5.1 )
+ vorbis? ( >=dev-python/pyvorbis-1.1 )"
+# flac? (
+# ~media-libs/flac-1.1.2
+# >=dev-lang/swig-1.3.25 )"
+
+RDEPEND="
+ >=dev-python/pyao-0.81
+ alsa? ( >=dev-python/pyalsaaudio-0.2 )
+ mp3? (
+ >=dev-python/pymad-0.4.1
+ >=dev-python/pyid3lib-0.5.1 )
+ vorbis? ( >=dev-python/pyvorbis-1.1 )"
+# flac? ( ~media-libs/flac-1.1.2 )"
+
+APPNAME=MusicBox
+APPCATEGORY="AudioVideo;Audio;Player"
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+# if use flac; then
+# if ! built_with_use dev-lang/swig python; then
+# einfo "MusicBox flac support requires swig with python support."
+# einfo "Please rebuild swig with USE=\"python\"."
+# die "swig python support missing"
+# fi
+# epatch ${FILESDIR}/${P}-fPIC.patch
+# fi
+ epatch ${FILESDIR}/${P}-mime.patch
+}
+
+# Special compilation needed for flac support
+src_compile() {
+# if use flac; then
+# cd "${S}/${APPNAME}/plugins/flac"
+# make || die "flac plugin compile failed."
+# fi
+ rox_src_compile
+}
+