summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2010-11-12 18:43:10 +0000
committerThomas Kahle <tomka@gentoo.org>2010-11-12 18:43:10 +0000
commit923775169386687e4fbee6928747ee3639c40d70 (patch)
tree0157997926a32cab6f032fa21e1a82adefd47427 /sci-libs/lrslib
parentVersion bump (diff)
downloadhistorical-923775169386687e4fbee6928747ee3639c40d70.tar.gz
historical-923775169386687e4fbee6928747ee3639c40d70.tar.bz2
historical-923775169386687e4fbee6928747ee3639c40d70.zip
New package: sci-libs/lrslib imported from science overlay. Fixes bug #338685
Package-Manager: portage-2.1.9.24/cvs/Linux i686
Diffstat (limited to 'sci-libs/lrslib')
-rw-r--r--sci-libs/lrslib/ChangeLog10
-rw-r--r--sci-libs/lrslib/Manifest14
-rw-r--r--sci-libs/lrslib/lrslib-042c.ebuild47
-rw-r--r--sci-libs/lrslib/metadata.xml15
4 files changed, 86 insertions, 0 deletions
diff --git a/sci-libs/lrslib/ChangeLog b/sci-libs/lrslib/ChangeLog
new file mode 100644
index 000000000000..fbace11a4f5c
--- /dev/null
+++ b/sci-libs/lrslib/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/lrslib
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lrslib/ChangeLog,v 1.1 2010/11/12 18:43:10 tomka Exp $
+
+*lrslib-042c (12 Nov 2010)
+
+ 12 Nov 2010; Thomas Kahle <tomka@gentoo.org> +lrslib-042c.ebuild,
+ +metadata.xml:
+ Initial import from science overlay. Fixes bug 338685
+
diff --git a/sci-libs/lrslib/Manifest b/sci-libs/lrslib/Manifest
new file mode 100644
index 000000000000..32983704498c
--- /dev/null
+++ b/sci-libs/lrslib/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST lrslib-042c.tar.gz 168765 RMD160 ada5b8b74808edb78c250d62147489381babdf49 SHA1 5614ea18725aa6a00f3deeb61d096f9e3564d753 SHA256 53f99b5271397bb5f317c96fa365edc1ac71fa7cba0295c8bd79e0882f5c3a4a
+EBUILD lrslib-042c.ebuild 1086 RMD160 7812948f3699853ac218f6800c9dcdac16c2aa30 SHA1 f5078dca7d6d4b836cc099bbfc6a8bf174077708 SHA256 36a48f8d0065e6d234fb933e7070e0d667ae76217789bce2375e70c0b96744d0
+MISC ChangeLog 372 RMD160 6eb9d293b85bf23823e1ab2589e2011402d1f426 SHA1 0d0b5a9fd6a3726d41f3a0b7ab8e816fab000ad6 SHA256 eb183508b2d331fb3f637b75f52019d06fe408c15f21603b6f4b03247bea0612
+MISC metadata.xml 765 RMD160 6236dbfa082c47dcb2550ea7d5d83b00feba353d SHA1 a025db1e00999783793f335ea824699a5ad2fd87 SHA256 3f81025eb334261ea725a7af08f2c4187a0b9f5c5790590b9fe89cc9325eae8e
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.16 (GNU/Linux)
+
+iEYEARECAAYFAkzdiuYACgkQnZsgo/h8kNZZPwCgq5VE5ZMPLzDuML0e2HkJGjlB
+mhYAn2sLTIUahOOjwrtg+atC4coUollO
+=+PKI
+-----END PGP SIGNATURE-----
diff --git a/sci-libs/lrslib/lrslib-042c.ebuild b/sci-libs/lrslib/lrslib-042c.ebuild
new file mode 100644
index 000000000000..ee5500874ea6
--- /dev/null
+++ b/sci-libs/lrslib/lrslib-042c.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lrslib/lrslib-042c.ebuild,v 1.1 2010/11/12 18:43:10 tomka Exp $
+
+EAPI=2
+
+inherit toolchain-funcs
+
+DESCRIPTION="self-contained ANSI C implementation of the reverse search algorithm"
+HOMEPAGE="http://cgm.cs.mcgill.ca/~avis/C/lrs.html"
+SRC_URI="http://cgm.cs.mcgill.ca/~avis/C/lrslib/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gmp"
+
+DEPEND="gmp? ( dev-libs/gmp )"
+RDEPEND="${DEPEND}"
+
+src_prepare(){
+ sed -i "s/gcc/$(tc-getCC)/g" makefile
+ sed -i "s/-O3/${CFLAGS} ${LDFLAGS}/g" makefile
+}
+
+src_compile () {
+ if use amd64 ; then
+ emake all64 || die "make failed"
+ else
+ emake || die "make failed"
+ fi
+ if use gmp ; then
+ emake gmp || die "make failed"
+ fi
+}
+
+src_install() {
+ dobin lrs redund redund1 buffer
+ if use x86; then
+ dobin nash setupnash setupnash2 2nash
+ # Prevent clash with cddlib:
+ newbin fourier lrsfourier
+ fi
+ use gmp && dobin glrs gnash gredund gfourier
+ dodoc readme
+ dohtml lrslib.html
+}
diff --git a/sci-libs/lrslib/metadata.xml b/sci-libs/lrslib/metadata.xml
new file mode 100644
index 000000000000..f8a5af1b110a
--- /dev/null
+++ b/sci-libs/lrslib/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tomka@gentoo.org</email>
+ <name>Thomas Kahle</name>
+ </maintainer>
+ <herd>sci</herd>
+ <longdescription>lrslib is a self-contained ANSI C implementation as a callable library of the
+ reverse search algorithm for vertex enumeration/convex hull problems and comes with a choice of
+ three arithmetic packages. Input file formats are compatible with Komei Fukuda's cdd package. All
+ computations are done exactly in either multiple precision or fixed integer arithmetic. Output is
+ not stored in memory, so even problems with very large output sizes can sometimes be
+ solved.</longdescription>
+</pkgmetadata>