summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-17 13:41:58 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-17 13:41:58 +0000
commit78c9bd886a28317ffe2b203d8421be69c67da314 (patch)
treee976710e32ece2a4047c86b7493255964e038e35 /sci-libs/mkl/mkl-10.0.5.025.ebuild
parentStable on alpha, bug #320687 (diff)
downloadhistorical-78c9bd886a28317ffe2b203d8421be69c67da314.tar.gz
historical-78c9bd886a28317ffe2b203d8421be69c67da314.tar.bz2
historical-78c9bd886a28317ffe2b203d8421be69c67da314.zip
Fix for bug 348935
Package-Manager: portage-2.2.0_alpha9/cvs/Linux x86_64
Diffstat (limited to 'sci-libs/mkl/mkl-10.0.5.025.ebuild')
-rw-r--r--sci-libs/mkl/mkl-10.0.5.025.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sci-libs/mkl/mkl-10.0.5.025.ebuild b/sci-libs/mkl/mkl-10.0.5.025.ebuild
index 3afe07a91f23..7f294ffab06d 100644
--- a/sci-libs/mkl/mkl-10.0.5.025.ebuild
+++ b/sci-libs/mkl/mkl-10.0.5.025.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mkl/mkl-10.0.5.025.ebuild,v 1.7 2010/12/17 08:24:38 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mkl/mkl-10.0.5.025.ebuild,v 1.8 2010/12/17 13:41:58 jlec Exp $
inherit eutils toolchain-funcs check-reqs
@@ -61,11 +61,11 @@ pkg_setup() {
# Check and setup fortran
if use fortran95; then
# blas95 and lapack95 don't compile with gfortran < 4.2
- [[ $(tc-getFC) =~ g* ]] && [[ $(gcc-major-version)$(gcc-minor-version) -lt 42 ]] &&
+ [[ $(tc-getFC) =~ g.* ]] && [[ $(gcc-major-version)$(gcc-minor-version) -lt 42 ]] &&
die "blas95 and lapack95 don't compile with gfortran < 4.2"
fi
MKL_FC="gnu"
- [[ $(tc-getFC) =~ if* ]] && MKL_FC="intel"
+ [[ $(tc-getFC) =~ if.* ]] && MKL_FC="intel"
# build profiles according to what compiler is installed
MKL_CC="gnu"