summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-01-27 16:04:29 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-01-27 16:04:29 +0000
commit2c2a528b6e4c54b2dcffcd9d0b723d55c315577f (patch)
treefe3693b8968cbaf561023213a1641d0ac3af1461 /sys-freebsd/freebsd-lib/freebsd-lib-9.1_rc3-r1.ebuild
parentunkeyworded razorqt-base/razorqt-lightdm-greeter on ppc and arm, so p.use.mas... (diff)
downloadhistorical-2c2a528b6e4c54b2dcffcd9d0b723d55c315577f.tar.gz
historical-2c2a528b6e4c54b2dcffcd9d0b723d55c315577f.tar.bz2
historical-2c2a528b6e4c54b2dcffcd9d0b723d55c315577f.zip
Crosscomilation support: Fix mtree dependency, append -isystem instead of -I otherwise gcc headers are picked up first which cause compile problems, bug #451490 by Yuta SATOH
Package-Manager: portage-2.2.0_alpha161/cvs/Linux x86_64 Manifest-Sign-Key: 0x160F534A
Diffstat (limited to 'sys-freebsd/freebsd-lib/freebsd-lib-9.1_rc3-r1.ebuild')
-rw-r--r--sys-freebsd/freebsd-lib/freebsd-lib-9.1_rc3-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-freebsd/freebsd-lib/freebsd-lib-9.1_rc3-r1.ebuild b/sys-freebsd/freebsd-lib/freebsd-lib-9.1_rc3-r1.ebuild
index 921938f0f28c..341f0eda4ef3 100644
--- a/sys-freebsd/freebsd-lib/freebsd-lib-9.1_rc3-r1.ebuild
+++ b/sys-freebsd/freebsd-lib/freebsd-lib-9.1_rc3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-9.1_rc3-r1.ebuild,v 1.3 2013/01/27 15:23:25 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-9.1_rc3-r1.ebuild,v 1.4 2013/01/27 16:04:21 aballier Exp $
EAPI=2
@@ -31,7 +31,6 @@ if [ "${CATEGORY#*cross-}" = "${CATEGORY}" ]; then
hesiod? ( net-dns/hesiod )
kerberos? ( virtual/krb5 )
usb? ( !dev-libs/libusb !dev-libs/libusbx )
- userland_GNU? ( sys-apps/mtree )
zfs? ( =sys-freebsd/freebsd-cddl-${RV}* )
>=dev-libs/expat-2.0.1
!sys-libs/libutempter
@@ -46,6 +45,7 @@ else
fi
DEPEND="${DEPEND}
+ userland_GNU? ( sys-apps/mtree )
=sys-freebsd/freebsd-mk-defs-${RV}*"
S="${WORKDIR}/lib"
@@ -337,7 +337,7 @@ src_compile() {
export YACC='yacc -by'
CHOST=${CTARGET} tc-export CC LD CXX RANLIB
mymakeopts="${mymakeopts} NLS="
- append-flags "-I/usr/${CTARGET}/usr/include"
+ CFLAGS="${CFLAGS} -isystem /usr/${CTARGET}/usr/include"
append-ldflags "-L${WORKDIR}/${CHOST}/${WORKDIR}/lib/libc"
fi