summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2008-10-15 03:05:19 +0000
committerJeroen Roovers <jer@gentoo.org>2008-10-15 03:05:19 +0000
commitb1522b3b41b580b144639e2ac44a185d4c8b0b7c (patch)
treefd56613a8f5a266f43d508e8ecff1fa1bd5c4d57 /sys-fs/squashfs-tools/squashfs-tools-3.4.ebuild
parentMarked ~hppa too. (diff)
downloadhistorical-b1522b3b41b580b144639e2ac44a185d4c8b0b7c.tar.gz
historical-b1522b3b41b580b144639e2ac44a185d4c8b0b7c.tar.bz2
historical-b1522b3b41b580b144639e2ac44a185d4c8b0b7c.zip
Pick up CFLAGS from the environment instead of "setting them in stone" (bug #242030).
Package-Manager: portage-2.2_rc12/cvs/Linux 2.6.25-gentoo-r7-JeR i686
Diffstat (limited to 'sys-fs/squashfs-tools/squashfs-tools-3.4.ebuild')
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-3.4.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-fs/squashfs-tools/squashfs-tools-3.4.ebuild b/sys-fs/squashfs-tools/squashfs-tools-3.4.ebuild
index 135afc4522d8..5da6d6ace800 100644
--- a/sys-fs/squashfs-tools/squashfs-tools-3.4.ebuild
+++ b/sys-fs/squashfs-tools/squashfs-tools-3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-3.4.ebuild,v 1.1 2008/08/28 03:36:00 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-3.4.ebuild,v 1.2 2008/10/15 03:05:19 jer Exp $
inherit toolchain-funcs
@@ -22,8 +22,8 @@ src_unpack() {
unpack ${A}
cd "${S}"
sed -i \
- -e "s:-O2:${CFLAGS}:" \
- -e 's:$(CC):$(CC) ${LDFLAGS}:' \
+ -e 's:-O2:$(CFLAGS):' \
+ -e 's:$(CC):$(CC) $(LDFLAGS):' \
Makefile || die "sed failed"
}