summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-03-01 07:13:43 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-03-01 07:13:43 +0000
commit0de97e441a0561bafce1cbee5c2a93e2a0e97e5c (patch)
treee4a5515beffc5c8cdc5861e154690dd1a049f857 /sys-libs/openipmi
parentFix bug 83612. (diff)
downloadhistorical-0de97e441a0561bafce1cbee5c2a93e2a0e97e5c.tar.gz
historical-0de97e441a0561bafce1cbee5c2a93e2a0e97e5c.tar.bz2
historical-0de97e441a0561bafce1cbee5c2a93e2a0e97e5c.zip
Initial commit, ebuilds by myself.
Package-Manager: portage-2.0.51.16
Diffstat (limited to 'sys-libs/openipmi')
-rw-r--r--sys-libs/openipmi/ChangeLog10
-rw-r--r--sys-libs/openipmi/Manifest4
-rw-r--r--sys-libs/openipmi/files/digest-openipmi-1.4.121
-rw-r--r--sys-libs/openipmi/metadata.xml8
-rw-r--r--sys-libs/openipmi/openipmi-1.4.12.ebuild39
5 files changed, 62 insertions, 0 deletions
diff --git a/sys-libs/openipmi/ChangeLog b/sys-libs/openipmi/ChangeLog
new file mode 100644
index 000000000000..36ec3cde992b
--- /dev/null
+++ b/sys-libs/openipmi/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-libs/openipmi
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/openipmi/ChangeLog,v 1.1 2005/03/01 07:13:43 robbat2 Exp $
+
+*openipmi-1.4.12 (28 Feb 2005)
+
+ 28 Feb 2005; Robin H. Johnson <robbat2@gentoo.org> +metadata.xml,
+ +openipmi-1.4.12.ebuild:
+ Initial commit, ebuilds by myself.
+
diff --git a/sys-libs/openipmi/Manifest b/sys-libs/openipmi/Manifest
new file mode 100644
index 000000000000..097725b21407
--- /dev/null
+++ b/sys-libs/openipmi/Manifest
@@ -0,0 +1,4 @@
+MD5 6349a3b360eeb6ac453837f66d7c1757 openipmi-1.4.12.ebuild 1169
+MD5 f5c09e21cbd282b3bf348549a65f1b1c ChangeLog 373
+MD5 21cd68602737d7c996bceabf6e62c468 metadata.xml 223
+MD5 d8b92faf5be2c84664830f92ed974b2f files/digest-openipmi-1.4.12 68
diff --git a/sys-libs/openipmi/files/digest-openipmi-1.4.12 b/sys-libs/openipmi/files/digest-openipmi-1.4.12
new file mode 100644
index 000000000000..1b4c24f7b85f
--- /dev/null
+++ b/sys-libs/openipmi/files/digest-openipmi-1.4.12
@@ -0,0 +1 @@
+MD5 5df8e7ba28f020eafc175b1624c8d837 OpenIPMI-1.4.12.tar.gz 1887180
diff --git a/sys-libs/openipmi/metadata.xml b/sys-libs/openipmi/metadata.xml
new file mode 100644
index 000000000000..5d9f5be9d49d
--- /dev/null
+++ b/sys-libs/openipmi/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/sys-libs/openipmi/openipmi-1.4.12.ebuild b/sys-libs/openipmi/openipmi-1.4.12.ebuild
new file mode 100644
index 000000000000..20093857df5a
--- /dev/null
+++ b/sys-libs/openipmi/openipmi-1.4.12.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/openipmi/openipmi-1.4.12.ebuild,v 1.1 2005/03/01 07:13:43 robbat2 Exp $
+
+DESCRIPTION="Library interface to IPMI"
+HOMEPAGE="http://sourceforge.net/projects/${PN}/"
+MY_PN="OpenIPMI"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="crypt snmp perl"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="virtual/libc
+ dev-libs/glib
+ >=dev-lang/swig-1.3.21
+ crypt? ( dev-libs/openssl )
+ snmp? ( net-analyzer/net-snmp )
+ perl? ( dev-lang/perl )"
+
+src_compile() {
+ local myconf=""
+ myconf="${myconf} `use_with snmp ucdsnmp yes`"
+ myconf="${myconf} `use_with crypt openssl yes`"
+ myconf="${myconf} `use_with perl perl yes`"
+ myconf="${myconf} --with-swig=yes --with-glib=yes"
+ # these binaries are for root!
+ econf ${myconf} --bindir=/usr/sbin || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc README* FAQ ChangeLog TODO doc/IPMI.pdf lanserv/README.emulator
+ newdoc cmdlang/README README.cmdlang
+}