summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-03-03 16:08:25 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-03-03 16:08:25 +0000
commit123b1fda0fb23741b3ebcd1b94eddb4521cb80ab (patch)
tree24783f06412ebdd5e3e6069d7da3a8e7340a6237 /sys-process/runit
parentMoved sys-apps/minit to sys-process/minit (diff)
downloadhistorical-123b1fda0fb23741b3ebcd1b94eddb4521cb80ab.tar.gz
historical-123b1fda0fb23741b3ebcd1b94eddb4521cb80ab.tar.bz2
historical-123b1fda0fb23741b3ebcd1b94eddb4521cb80ab.zip
Moved from sys-apps/runit to sys-process/runit.
Diffstat (limited to 'sys-process/runit')
-rw-r--r--sys-process/runit/ChangeLog15
-rw-r--r--sys-process/runit/Manifest10
-rwxr-xr-xsys-process/runit/files/110
-rwxr-xr-xsys-process/runit/files/26
-rwxr-xr-xsys-process/runit/files/315
-rwxr-xr-xsys-process/runit/files/ctrlaltdel9
-rw-r--r--sys-process/runit/files/digest-runit-1.0.51
-rwxr-xr-xsys-process/runit/files/finish.getty2
-rwxr-xr-xsys-process/runit/files/run.getty2
-rw-r--r--sys-process/runit/metadata.xml5
-rw-r--r--sys-process/runit/runit-1.0.5.ebuild64
11 files changed, 139 insertions, 0 deletions
diff --git a/sys-process/runit/ChangeLog b/sys-process/runit/ChangeLog
new file mode 100644
index 000000000000..e691fab7f49d
--- /dev/null
+++ b/sys-process/runit/ChangeLog
@@ -0,0 +1,15 @@
+# ChangeLog for sys-apps/runit
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/runit/ChangeLog,v 1.1 2005/03/03 16:08:25 ciaranm Exp $
+
+*runit-1.0.5 (03 Mar 2005)
+
+ 03 Mar 2005; Ciaran McCreesh <ciaranm@gentoo.org> +metadata.xml, +files/1,
+ +files/2, +files/3, +files/ctrlaltdel, +files/finish.getty,
+ +files/run.getty, +runit-1.0.5.ebuild:
+ Moved from sys-apps/runit to sys-process/runit.
+
+*runit-1.0.5 (09 Oct 2004)
+
+ 09 Oct 2004; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by Torne Wuff #39160.
diff --git a/sys-process/runit/Manifest b/sys-process/runit/Manifest
new file mode 100644
index 000000000000..1bb2e2b62d26
--- /dev/null
+++ b/sys-process/runit/Manifest
@@ -0,0 +1,10 @@
+MD5 6c0cd248ea4b64148f724d8705f056dd ChangeLog 339
+MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
+MD5 409b93fd717256e36666db62a210bc0b runit-1.0.5.ebuild 1663
+MD5 c40ea29a84ae96a8d38976a36c963335 files/1 175
+MD5 3b574bfad17bf4d2d22e025289d2bad7 files/2 551
+MD5 14c3375cd167d9c7b1b89febd8de64e6 files/3 377
+MD5 9f1dcf4c31a2d9df9336b8d1c9b13a83 files/ctrlaltdel 189
+MD5 0c9a4b2732a7c102b84593eae16b34c7 files/digest-runit-1.0.5 62
+MD5 ca1dc1a0ccab2afbac7a8540c74bd612 files/finish.getty 30
+MD5 2d1e9a75a18249dec3a71503c5266d55 files/run.getty 44
diff --git a/sys-process/runit/files/1 b/sys-process/runit/files/1
new file mode 100755
index 000000000000..d6a5b4f64eeb
--- /dev/null
+++ b/sys-process/runit/files/1
@@ -0,0 +1,10 @@
+#!/bin/sh
+# system one time tasks
+
+PATH=/sbin:/usr/sbin:/bin:/usr/bin
+
+RUNLEVEL=S /sbin/rc sysinit
+RUNLEVEL=S /sbin/rc boot
+
+touch /etc/runit/stopit
+chmod 0 /etc/runit/stopit
diff --git a/sys-process/runit/files/2 b/sys-process/runit/files/2
new file mode 100755
index 000000000000..233ad006aac3
--- /dev/null
+++ b/sys-process/runit/files/2
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+PATH=/command:/usr/local/bin:/usr/local/sbin:/bin:/sbin:/usr/bin:/usr/sbin:/usr/X11R6/bin
+
+exec env - PATH=$PATH \
+runsvdir /var/service 'log: ...........................................................................................................................................................................................................................................................................................................................................................................................................'
diff --git a/sys-process/runit/files/3 b/sys-process/runit/files/3
new file mode 100755
index 000000000000..182151e723d0
--- /dev/null
+++ b/sys-process/runit/files/3
@@ -0,0 +1,15 @@
+#!/bin/sh
+exec >/dev/console 2>&1
+PATH=/sbin:/usr/sbin:/bin:/usr/bin
+
+echo 'Waiting for getties to stop...'
+svwaitdown -xk -t10 /var/service/getty-*
+
+echo 'Waiting for services to stop...'
+svwaitdown -xk -t300 /var/service/*
+
+echo 'Shutdown...'
+test -x /etc/runit/reboot && LAST=6 || LAST=0
+test -x /etc/runit/reboot && RC=reboot || RC=shutdown
+RUNLEVEL=$LAST /sbin/rc $RC
+
diff --git a/sys-process/runit/files/ctrlaltdel b/sys-process/runit/files/ctrlaltdel
new file mode 100755
index 000000000000..668445738dfc
--- /dev/null
+++ b/sys-process/runit/files/ctrlaltdel
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+PATH=/bin:/usr/bin
+MSG="System is going down in 14 seconds..."
+
+# echo 'disabled.' ; exit
+touch /etc/runit/stopit
+chmod 100 /etc/runit/stopit && echo "$MSG" | wall
+/bin/sleep 14
diff --git a/sys-process/runit/files/digest-runit-1.0.5 b/sys-process/runit/files/digest-runit-1.0.5
new file mode 100644
index 000000000000..3179a3bb2ec0
--- /dev/null
+++ b/sys-process/runit/files/digest-runit-1.0.5
@@ -0,0 +1 @@
+MD5 e90ed8f2f37fae157b0f422ff6e594cb runit-1.0.5.tar.gz 89541
diff --git a/sys-process/runit/files/finish.getty b/sys-process/runit/files/finish.getty
new file mode 100755
index 000000000000..c3d440a85e38
--- /dev/null
+++ b/sys-process/runit/files/finish.getty
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec utmpset -w TTY
diff --git a/sys-process/runit/files/run.getty b/sys-process/runit/files/run.getty
new file mode 100755
index 000000000000..ab6f9543fe97
--- /dev/null
+++ b/sys-process/runit/files/run.getty
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec /sbin/agetty 38400 TTY linux
diff --git a/sys-process/runit/metadata.xml b/sys-process/runit/metadata.xml
new file mode 100644
index 000000000000..96a2d586367d
--- /dev/null
+++ b/sys-process/runit/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+</pkgmetadata>
diff --git a/sys-process/runit/runit-1.0.5.ebuild b/sys-process/runit/runit-1.0.5.ebuild
new file mode 100644
index 000000000000..e02684da7cd7
--- /dev/null
+++ b/sys-process/runit/runit-1.0.5.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/runit/runit-1.0.5.ebuild,v 1.1 2005/03/03 16:08:25 ciaranm Exp $
+
+inherit gcc flag-o-matic
+
+DESCRIPTION="A UNIX init scheme with service supervision"
+HOMEPAGE="http://smarden.org/runit/"
+SRC_URI="http://smarden.org/runit/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="static"
+
+DEPEND="virtual/libc"
+
+S=${WORKDIR}/admin/${P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # we either build everything or nothing static
+ sed -i -e 's:-static: :' src/Makefile
+ use static && append-ldflags -static
+
+ echo "$(gcc-getCC) ${CFLAGS}" > src/conf-cc
+ echo "$(gcc-getCC) ${LDFLAGS}" > src/conf-ld
+}
+
+src_compile() {
+ cd src
+ emake || die "make failed"
+}
+
+src_install() {
+ dodir /var
+ keepdir /etc/runit{,/runsvdir{,/default,/all}}
+ dosym default /etc/runit/runsvdir/current
+ dosym ../etc/runit/runsvdir/current /var/service
+
+ cd src
+ dobin chpst runsv runsvchdir runsvctrl runsvdir \
+ runsvstat svlogd svwaitdown svwaitup || die "dobin"
+ into /
+ dosbin runit-init runit utmpset || die "dosbin"
+
+ cd ${S}
+ dodoc package/{CHANGES,README,THANKS}
+ dohtml doc/*.html
+ doman man/*
+
+ exeinto /etc/runit/
+ doexe ${FILESDIR}/{1,2,3,ctrlaltdel}
+ for tty in tty1 tty2 tty3 tty4 tty5 tty6; do
+ exeinto /etc/runit/runsvdir/all/getty-$tty/
+ for script in run finish; do
+ newexe ${FILESDIR}/$script.getty $script
+ dosed "s:TTY:${tty}:g" /etc/runit/runsvdir/all/getty-$tty/$script
+ done
+ dosym ../all/getty-$tty /etc/runit/runsvdir/default/getty-$tty
+ done
+}