summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-06 12:54:20 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-06 12:54:20 +0000
commit3dc7437714df9c3d854c5b6f02d1989524509fc8 (patch)
tree23648b8a8b3fa5ed78c4046cb000070549d9a93a /x11-base
parentx86 stable (diff)
downloadhistorical-3dc7437714df9c3d854c5b6f02d1989524509fc8.tar.gz
historical-3dc7437714df9c3d854c5b6f02d1989524509fc8.tar.bz2
historical-3dc7437714df9c3d854c5b6f02d1989524509fc8.zip
fix flag filtering
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xfree/xfree-4.3.0-r2.ebuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/x11-base/xfree/xfree-4.3.0-r2.ebuild b/x11-base/xfree/xfree-4.3.0-r2.ebuild
index c7a0b77ed558..0185ab28eb76 100644
--- a/x11-base/xfree/xfree-4.3.0-r2.ebuild
+++ b/x11-base/xfree/xfree-4.3.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xfree/xfree-4.3.0-r2.ebuild,v 1.52 2004/01/27 11:53:57 cyfred Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xfree/xfree-4.3.0-r2.ebuild,v 1.53 2004/02/06 12:54:20 vapier Exp $
# Make sure Portage does _NOT_ strip symbols. We will do it later and make sure
# that only we only strip stuff that are safe to strip ...
@@ -8,11 +8,6 @@ RESTRICT="nostrip"
IUSE="3dfx sse mmx 3dnow xml truetype nls cjk doc bindist pam"
-
-filter-flags "-funroll-loops"
-
-ALLOWED_FLAGS="-fstack-protector -march -mcpu -O -O2 -O3 -pipe"
-
# Recently there has been a lot of stability problem in Gentoo-land. Many
# things can be the cause to this, but I believe that it is due to gcc3
# still having issues with optimizations, or with it not filtering bad
@@ -33,13 +28,6 @@ ALLOWED_FLAGS="-fstack-protector -march -mcpu -O -O2 -O3 -pipe"
# problems.
#
# <azarah@gentoo.org> (13 Oct 2002)
-strip-flags
-
-# Needed by kdebase on hppa
-[ "${ARCH}" = "hppa" ] && append-flags -fPIC
-
-# http://www.gentoo.org/proj/en/hardened/etdyn-ssp.xml
-has_version "sys-devel/hardened-gcc" && export CC="${CC} -yet_exec"
# Are we using a snapshot ?
USE_SNAPSHOT="no"
@@ -272,6 +260,16 @@ src_unpack() {
echo "#define InstallXserverSetUID NO" >> config/cf/host.def
echo "#define BuildServersOnly NO" >> config/cf/host.def
+ filter-flags -funroll-loops
+ ALLOWED_FLAGS="-fstack-protector -march -mcpu -O -O2 -O3 -pipe"
+ strip-flags
+
+ # Needed by kdebase on hppa
+ [ "${ARCH}" = "hppa" ] && append-flags -fPIC
+
+ # http://www.gentoo.org/proj/en/hardened/etdyn-ssp.xml
+ has_version "sys-devel/hardened-gcc" && export CC="${CC} -yet_exec"
+
# Bug #12775 .. fails with -Os.
replace-flags "-Os" "-O2"