summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-03-12 16:38:30 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-03-12 16:38:30 +0000
commit11ff6b2681e9d66c10f34478633c70d6d8cf6298 (patch)
treebebe0c15d10cc075a884116b90a8d07e5569a585 /x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.0-r1.ebuild
parentAlso respect PORTAGE_CONFIGROOT in various utils. (diff)
downloadhistorical-11ff6b2681e9d66c10f34478633c70d6d8cf6298.tar.gz
historical-11ff6b2681e9d66c10f34478633c70d6d8cf6298.tar.bz2
historical-11ff6b2681e9d66c10f34478633c70d6d8cf6298.zip
Fix building against xorg-server-1.14
Package-Manager: portage-2.1.11.52/cvs/Linux x86_64
Diffstat (limited to 'x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.0-r1.ebuild')
-rw-r--r--x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.0-r1.ebuild b/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.0-r1.ebuild
new file mode 100644
index 000000000000..4b2ad5b514aa
--- /dev/null
+++ b/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-qxl/xf86-video-qxl-0.1.0-r1.ebuild,v 1.1 2013/03/12 16:36:30 chithanh Exp $
+
+EAPI=5
+inherit xorg-2
+
+DESCRIPTION="QEMU QXL paravirt video driver"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="xspice"
+
+RDEPEND="xspice? ( app-emulation/spice )
+ x11-base/xorg-server[-minimal]"
+DEPEND="${RDEPEND}
+ x11-proto/xf86dgaproto
+ >=app-emulation/spice-protocol-0.12.0"
+
+pkg_setup() {
+ xorg-2_pkg_setup
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable xspice)
+ )
+}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-remove-mibstore_h.patch
+)