summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-10-04 18:27:17 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-10-04 18:27:17 +0000
commit8f2f291c37eb1d5b9d7ba7c3c5eabbab59eb1e39 (patch)
treed03bfc3f568531585a824b1e2d2c0c44e160ed2a /x11-themes/gtk-engines-mist/gtk-engines-mist-0.10.ebuild
parentchangelog:p (diff)
downloadhistorical-8f2f291c37eb1d5b9d7ba7c3c5eabbab59eb1e39.tar.gz
historical-8f2f291c37eb1d5b9d7ba7c3c5eabbab59eb1e39.tar.bz2
historical-8f2f291c37eb1d5b9d7ba7c3c5eabbab59eb1e39.zip
fix 0.10 first, then maybe we need to get to 0.8
Diffstat (limited to 'x11-themes/gtk-engines-mist/gtk-engines-mist-0.10.ebuild')
-rw-r--r--x11-themes/gtk-engines-mist/gtk-engines-mist-0.10.ebuild31
1 files changed, 27 insertions, 4 deletions
diff --git a/x11-themes/gtk-engines-mist/gtk-engines-mist-0.10.ebuild b/x11-themes/gtk-engines-mist/gtk-engines-mist-0.10.ebuild
index 6e2d904b8676..36c2d595ba99 100644
--- a/x11-themes/gtk-engines-mist/gtk-engines-mist-0.10.ebuild
+++ b/x11-themes/gtk-engines-mist/gtk-engines-mist-0.10.ebuild
@@ -1,21 +1,44 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-mist/gtk-engines-mist-0.10.ebuild,v 1.1 2003/06/19 09:48:44 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-mist/gtk-engines-mist-0.10.ebuild,v 1.2 2003/10/04 18:27:13 liquidx Exp $
inherit gtk-engines2
MY_P="${P/engines-mist/mist-engine}"
IUSE=""
-DESCRIPTION="GTK+2 Mist Theme Engine"
+DESCRIPTION="GTK+1 and GTK+2 Mist Theme Engine"
HOMEPAGE="http://primates.ximian.com/~dave/mist/"
SRC_URI="http://primates.ximian.com/~dave/mist/${MY_P}.tar.gz"
KEYWORDS="~x86 ~ppc ~alpha ~sparc"
LICENSE="GPL-2"
SLOT="2"
-DEPEND=">=x11-libs/gtk+-2
- !x11-themes/gnome-themes"
+DEPEND="!x11-themes/gnome-themes"
S=${WORKDIR}/${MY_P}
+src_unpack() {
+ unpack ${A}
+ # patch that adds --[enable|disable]-gtk-[1|2] - liquidx@g.o (04 Oct 03)
+ epatch ${FILESDIR}/${P}-autoconf.patch
+ cd ${S}; aclocal; automake; autoconf
+}
+
+src_compile() {
+ local myconf
+ if [ -n "${HAS_GTK1}" ]; then
+ myconf="${myconf} --enable-gtk-1"
+ else
+ myconf="${myconf} --disable-gtk-1"
+ fi
+
+ if [ -n "${HAS_GTK2}" ]; then
+ myconf="${myconf} --enable-gtk-2"
+ else
+ myconf="${myconf} --disable-gtk-2"
+ fi
+
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+}