summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2010-05-22 17:07:38 +0000
committerChristoph Mende <angelos@gentoo.org>2010-05-22 17:07:38 +0000
commit33ae1d1f2094506a9a445738020abe3cbc4a33ff (patch)
treed79a189558b0619a81b02f499b19bdb44f5eefd9 /xfce-base
parentVersoin bump (diff)
downloadhistorical-33ae1d1f2094506a9a445738020abe3cbc4a33ff.tar.gz
historical-33ae1d1f2094506a9a445738020abe3cbc4a33ff.tar.bz2
historical-33ae1d1f2094506a9a445738020abe3cbc4a33ff.zip
Version bump
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfconf/ChangeLog7
-rw-r--r--xfce-base/xfconf/xfconf-4.6.2.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/xfce-base/xfconf/ChangeLog b/xfce-base/xfconf/ChangeLog
index ae4887c2dad7..6ad3235f3c43 100644
--- a/xfce-base/xfconf/ChangeLog
+++ b/xfce-base/xfconf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/xfconf
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/ChangeLog,v 1.30 2010/04/14 18:55:08 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/ChangeLog,v 1.31 2010/05/22 17:07:38 angelos Exp $
+
+*xfconf-4.6.2 (22 May 2010)
+
+ 22 May 2010; Christoph Mende <angelos@gentoo.org> +xfconf-4.6.2.ebuild:
+ Version bump
14 Apr 2010; Raúl Porcel <armin76@gentoo.org> xfconf-4.6.1-r1.ebuild:
sh stable
diff --git a/xfce-base/xfconf/xfconf-4.6.2.ebuild b/xfce-base/xfconf/xfconf-4.6.2.ebuild
new file mode 100644
index 000000000000..c5fd3284410d
--- /dev/null
+++ b/xfce-base/xfconf/xfconf-4.6.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/xfconf-4.6.2.ebuild,v 1.1 2010/05/22 17:07:38 angelos Exp $
+
+EAPI=2
+inherit xfconf
+
+DESCRIPTION="Xfce configuration daemon and utilities"
+HOMEPAGE="http://www.xfce.org"
+SRC_URI="mirror://xfce/src/xfce/${PN}/4.6/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug -perl profile"
+
+RDEPEND=">=dev-libs/dbus-glib-0.72
+ >=dev-libs/glib-2.12:2
+ >=xfce-base/libxfce4util-4.6
+ perl? ( dev-perl/glib-perl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext
+ perl? ( dev-perl/extutils-depends
+ dev-perl/extutils-pkgconfig )"
+
+RESTRICT="test"
+
+pkg_setup() {
+ XFCONF="--disable-dependency-tracking
+ --disable-static
+ --with-perl-options=INSTALLDIRS=vendor
+ $(use_enable perl perl-bindings)
+ $(use_enable debug)
+ $(use_enable debug checks)"
+ use profile && XFCONF="${XFCONF} --enable-profiling"
+ DOCS="AUTHORS ChangeLog NEWS TODO"
+}
+
+src_compile() {
+ emake OTHERLDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ xfconf_src_install
+
+ if use perl; then
+ # Prefix compat. In Gentoo Linux, defaults to ${D}
+ [[ -z ${ED} ]] && local ED=${D}
+ find "${ED}" -type f -name perllocal.pod -delete
+ find "${ED}" -depth -mindepth 1 -type d -empty -delete
+ fi
+}