summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-05-19 21:05:07 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-05-19 21:05:07 +0000
commitb0f82f98c98b81809f337ba9acf3809eed5951bd (patch)
tree01d9b4ca9420ce4bbf64c2bc84a314dc683f9ef0 /xfce-extra/xfce4-genmon-plugin
parentversion bump (diff)
downloadhistorical-b0f82f98c98b81809f337ba9acf3809eed5951bd.tar.gz
historical-b0f82f98c98b81809f337ba9acf3809eed5951bd.tar.bz2
historical-b0f82f98c98b81809f337ba9acf3809eed5951bd.zip
EAPI4
Package-Manager: portage-2.2.0_alpha33/cvs/Linux x86_64
Diffstat (limited to 'xfce-extra/xfce4-genmon-plugin')
-rw-r--r--xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.2.ebuild17
-rw-r--r--xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.3.0.ebuild16
2 files changed, 12 insertions, 21 deletions
diff --git a/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.2.ebuild b/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.2.ebuild
index a85443d8fa68..e67ead34abca 100644
--- a/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.2.ebuild
+++ b/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.2.ebuild,v 1.5 2011/03/22 15:21:02 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.2.ebuild,v 1.6 2011/05/19 21:03:41 ssuominen Exp $
-EAPI=3
+EAPI=4
EAUTORECONF=yes
inherit xfconf
@@ -15,19 +15,14 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
IUSE="debug"
-RDEPEND=">=xfce-base/libxfcegui4-4.3.22
- >=xfce-base/xfce4-panel-4.3.22"
+RDEPEND=">=xfce-base/libxfcegui4-4.8
+ >=xfce-base/xfce4-panel-4.8"
DEPEND="${RDEPEND}
dev-util/intltool
dev-util/pkgconfig"
pkg_setup() {
PATCHES=( "${FILESDIR}"/${P}-link_to_libxfcegui4.patch )
-
- XFCONF=(
- --disable-dependency-tracking
- $(xfconf_use_debug)
- )
-
- DOCS="AUTHORS ChangeLog README"
+ XFCONF=( $(xfconf_use_debug) )
+ DOCS=( AUTHORS ChangeLog README )
}
diff --git a/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.3.0.ebuild b/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.3.0.ebuild
index c78c592c645b..fe7f824653ec 100644
--- a/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.3.0.ebuild
+++ b/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.3.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.3.0.ebuild,v 1.2 2011/03/22 15:21:02 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-3.3.0.ebuild,v 1.3 2011/05/19 21:03:41 ssuominen Exp $
-EAPI=3
+EAPI=4
inherit xfconf
DESCRIPTION="Cyclically spawns the executable, captures its output and displays the result into the panel."
@@ -14,17 +14,13 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
IUSE="debug"
-RDEPEND=">=xfce-base/libxfcegui4-4.3.22
- >=xfce-base/xfce4-panel-4.3.22"
+RDEPEND=">=xfce-base/libxfcegui4-4.8
+ >=xfce-base/xfce4-panel-4.8"
DEPEND="${RDEPEND}
dev-util/intltool
dev-util/pkgconfig"
pkg_setup() {
- XFCONF=(
- --disable-dependency-tracking
- $(xfconf_use_debug)
- )
-
- DOCS="AUTHORS ChangeLog NEWS README"
+ XFCONF=( $(xfconf_use_debug) )
+ DOCS=( AUTHORS ChangeLog NEWS README )
}