summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-dns/ez-ipupdate/ChangeLog13
-rw-r--r--net-dns/ez-ipupdate/Manifest18
-rw-r--r--net-dns/ez-ipupdate/ez-ipupdate-3.0.11_beta8-r2.ebuild95
-rw-r--r--net-dns/ez-ipupdate/files/digest-ez-ipupdate-3.0.11_beta8-r22
-rw-r--r--net-dns/ez-ipupdate/files/ez-ipupdate.initd93
-rw-r--r--net-dns/ez-ipupdate/metadata.xml14
6 files changed, 221 insertions, 14 deletions
diff --git a/net-dns/ez-ipupdate/ChangeLog b/net-dns/ez-ipupdate/ChangeLog
index 155f60164b63..6496d3e92e30 100644
--- a/net-dns/ez-ipupdate/ChangeLog
+++ b/net-dns/ez-ipupdate/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-dns/ez-ipupdate
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/ez-ipupdate/ChangeLog,v 1.12 2004/12/11 20:18:38 swegener Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ez-ipupdate/ChangeLog,v 1.13 2005/10/09 22:48:07 sbriesen Exp $
+
+*ez-ipupdate-3.0.11_beta8-r2 (09 Oct 2005)
+
+ 09 Oct 2005; Stefan Briesenick <sbriesen@gentoo.org>
+ +files/ez-ipupdate.initd, +metadata.xml,
+ +ez-ipupdate-3.0.11_beta8-r2.ebuild:
+ Switching to debian sources which contain all security fixes. Original
+ source is not available anymore. Ebuild completely rewritten, init-script
+ now handles more than one config. Solving bug #85158.
11 Dec 2004; Sven Wegener <swegener@gentoo.org>
ez-ipupdate-3.0.11_beta8-r1.ebuild:
diff --git a/net-dns/ez-ipupdate/Manifest b/net-dns/ez-ipupdate/Manifest
index 139aa9615507..c29cd8c11c80 100644
--- a/net-dns/ez-ipupdate/Manifest
+++ b/net-dns/ez-ipupdate/Manifest
@@ -1,15 +1,9 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 e347e3dc3effd7493b6f02fabab3110b ChangeLog 2444
MD5 f4ad9aeaf2a00fbbbe49f843df2ba3bd ez-ipupdate-3.0.11_beta8-r1.ebuild 908
-MD5 fedc0f173e198239dc59f80a90104cec ChangeLog 2057
-MD5 cce1451ebc90d2c8a8068f6fe7d7a875 files/ez-ipupdate.rc6 1226
+MD5 1b14c90a17534ac7efdcc3bc51909861 ez-ipupdate-3.0.11_beta8-r2.ebuild 2717
MD5 fc53ff461d5187c04a36e96c42f0d7e2 files/digest-ez-ipupdate-3.0.11_beta8-r1 71
+MD5 73bb146a959cd541212ee2dc87127303 files/digest-ez-ipupdate-3.0.11_beta8-r2 152
MD5 a4f8cd6940114080f701918bd00b1800 files/ez-ipupdate-3.0.11_beta8-syslog.patch 300
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.10 (GNU/Linux)
-
-iD8DBQFBu1YmI1lqEGTUzyQRAg5BAKCQOLKRSwfhpbXHZN+0F61J+SWHpgCfULsj
-QDd73cenuXrEEOcu4QR36jI=
-=dD10
------END PGP SIGNATURE-----
+MD5 a86f6c45f48dc904e4d9a9447226889e files/ez-ipupdate.initd 2658
+MD5 cce1451ebc90d2c8a8068f6fe7d7a875 files/ez-ipupdate.rc6 1226
+MD5 414df12ae436dd1300fe77e5549da485 metadata.xml 497
diff --git a/net-dns/ez-ipupdate/ez-ipupdate-3.0.11_beta8-r2.ebuild b/net-dns/ez-ipupdate/ez-ipupdate-3.0.11_beta8-r2.ebuild
new file mode 100644
index 000000000000..669fbbb44cdb
--- /dev/null
+++ b/net-dns/ez-ipupdate/ez-ipupdate-3.0.11_beta8-r2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ez-ipupdate/ez-ipupdate-3.0.11_beta8-r2.ebuild,v 1.1 2005/10/09 22:48:08 sbriesen Exp $
+
+inherit eutils
+
+PATCH_VERSION="8.1"
+MY_PV="${PV/_beta/b}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DESCRIPTION="Dynamic DNS client for lots of dynamic dns services"
+HOMEPAGE="http://ez-ipupdate.com/"
+SRC_URI="mirror://debian/pool/main/e/ez-ipupdate/${PN}_${MY_PV}.orig.tar.gz
+ mirror://debian/pool/main/e/ez-ipupdate/${PN}_${MY_PV}-${PATCH_VERSION}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}/${PN}_${MY_PV}-${PATCH_VERSION}.diff"
+}
+
+src_compile() {
+ econf --bindir=/usr/sbin || "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ newinitd "${FILESDIR}/ez-ipupdate.initd" ez-ipupdate
+ keepdir /etc/ez-ipupdate /var/cache/ez-ipupdate
+
+ # install docs
+ dodoc README
+ newdoc debian/README.Debian README.debian
+ newdoc debian/changelog ChangeLog.debian
+ newdoc CHANGELOG ChangeLog
+
+ # install example configs
+ docinto examples
+ dodoc ex*conf
+}
+
+pkg_preinst() {
+ enewgroup ez-ipupd
+ enewuser ez-ipupd -1 /bin/false /var/cache/ez-ipupdate ez-ipupd
+}
+
+pkg_postinst() {
+ chmod 750 /etc/ez-ipupdate /var/cache/ez-ipupdate
+ chown ez-ipupd:ez-ipupd /etc/ez-ipupdate /var/cache/ez-ipupdate
+
+ einfo
+ einfo "Please create one or more config files in"
+ einfo "/etc/ez-ipupdate/. A bunch of samples can"
+ einfo "be found in the doc directory."
+ einfo
+ einfo "All config files must have a '.conf' extension."
+ einfo
+ einfo "Please do not use the 'run-as-user', 'run-as-euser',"
+ einfo "'cache-file' and 'pidfile' options, since these are"
+ einfo "handled internally by the init-script!"
+ einfo
+ einfo "If you want to use ez-ipupdate in daemon mode,"
+ einfo "please add 'daemon' to the config file(s) and"
+ einfo "add the ez-ipupdate init-script to the default"
+ einfo "runlevel."
+ einfo
+ einfo "Without the 'daemon' option, you can run the"
+ einfo "init-script with the 'update' parameter inside"
+ einfo "your PPP ip-up script."
+ einfo
+
+ if [ -f /etc/ez-ipupdate.conf ]; then
+ ewarn "!!! IMPORTANT UPDATE NOTICE !!!"
+ ewarn
+ ewarn "The ez-ipupdate init-script can now handle more"
+ ewarn "than one config file. New config file location is"
+ ewarn "/etc/ez-ipupdate/*.conf"
+ ewarn
+ if [ ! -f /etc/ez-ipupdate/default.conf ]; then
+ mv -f /etc/ez-ipupdate.conf /etc/ez-ipupdate/default.conf
+ einfo "Your old configuration has been moved to"
+ einfo "/etc/ez-ipupdate/default.conf"
+ einfo
+ fi
+ ebeep
+ fi
+}
diff --git a/net-dns/ez-ipupdate/files/digest-ez-ipupdate-3.0.11_beta8-r2 b/net-dns/ez-ipupdate/files/digest-ez-ipupdate-3.0.11_beta8-r2
new file mode 100644
index 000000000000..0448b3422f94
--- /dev/null
+++ b/net-dns/ez-ipupdate/files/digest-ez-ipupdate-3.0.11_beta8-r2
@@ -0,0 +1,2 @@
+MD5 42b3cc116dcfd90066b747545dfde465 ez-ipupdate_3.0.11b8-8.1.diff.gz 54073
+MD5 000211add4c4845ffa4211841bff4fb0 ez-ipupdate_3.0.11b8.orig.tar.gz 81975
diff --git a/net-dns/ez-ipupdate/files/ez-ipupdate.initd b/net-dns/ez-ipupdate/files/ez-ipupdate.initd
new file mode 100644
index 000000000000..82a9c60aeada
--- /dev/null
+++ b/net-dns/ez-ipupdate/files/ez-ipupdate.initd
@@ -0,0 +1,93 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ez-ipupdate/files/ez-ipupdate.initd,v 1.1 2005/10/09 22:48:08 sbriesen Exp $
+
+opts="${opts} update"
+
+depend() {
+ need net
+}
+
+getconfig() { # 0: no daemon / 1: daemon
+ local CONF NAME LIST=""
+ for CONF in /etc/ez-ipupdate/*.conf; do
+ if [ -f "${CONF}" ]; then
+ # Don't run configurations that are (not) daemons
+ grep -q '^[[:space:]]*daemon' "${CONF}"; [ $? -eq $1 ] && continue
+ # Don't run configurations that run in the foreground
+ grep -q '^[[:space:]]*foreground' "${CONF}" && continue
+ # add config to list
+ NAME="${CONF##*/}"
+ LIST="${LIST} ${NAME%.*}"
+ fi
+ done
+ echo ${LIST}
+}
+
+start() {
+ local NAME LIST=$(getconfig 1)
+
+ if [ -z "${LIST}" ]; then
+ eerror "You need at least one config file in /etc/ez-ipupdate"
+ eerror "containing the 'daemon' keyword and no 'foreground' keyword."
+ return 1
+ fi
+
+ if [ ! -d /var/run/ez-ipupdate ]; then
+ mkdir -p /var/run/ez-ipupdate && chown ez-ipupd:ez-ipupd /var/run/ez-ipupdate
+ fi
+
+ for NAME in ${LIST}; do
+ local CONFIG="/etc/ez-ipupdate/${NAME}.conf"
+ local PIDFILE="/var/run/ez-ipupdate/${NAME}.pid"
+ local CACHEFILE="/var/cache/ez-ipupdate/${NAME}.cache"
+ ebegin "Starting ez-ipupdate (${NAME})"
+ start-stop-daemon -p "${PIDFILE}" --start --quiet --exec /usr/sbin/ez-ipupdate \
+ --chuid ez-ipupd -- -c "${CONFIG}" -F "${PIDFILE}" -b "${CACHEFILE}"
+ eend $?
+ done
+ return 0 # do not fail
+}
+
+stop() {
+ local PIDFILE NAME
+ for PIDFILE in /var/run/ez-ipupdate/*.pid; do
+ if [ -f "${PIDFILE}" ]; then
+ NAME="${PIDFILE##*/}"
+ ebegin "Stopping ez-ipupdate (${NAME%.*})"
+ start-stop-daemon --stop --signal QUIT --quiet --pidfile "${PIDFILE}"
+ eend $? || rm -f "${PIDFILE}"
+ else
+ eerror "No running ez-ipupdate process"
+ fi
+ done
+ return 0 # do not fail
+}
+
+update() {
+ local NAME TEXT LIST=$(getconfig 0)
+
+ if [ -z "${LIST}" ]; then
+ eerror "You need at least one config file in /etc/ez-ipupdate"
+ eerror "containing no 'daemon' and 'foreground' keyword."
+ return 1
+ fi
+
+ for NAME in ${LIST}; do
+ local CONFIG="/etc/ez-ipupdate/${NAME}.conf"
+ local CACHEFILE="/var/cache/ez-ipupdate/${NAME}.cache"
+ ebegin "Running ez-ipupdate (${NAME})"
+ TEXT=$(/usr/sbin/ez-ipupdate -q -R ez-ipupd -c "${CONFIG}" -b "${CACHEFILE}" 2>&1)
+ if eend $?; then
+ if [ -n "${TEXT}" ]; then
+ while read line; do einfo " $line"; done < <(echo "${TEXT}")
+ fi
+ else
+ if [ -n "${TEXT}" ]; then
+ while read line; do eerror " $line"; done < <(echo "${TEXT}")
+ fi
+ fi
+ done
+ return 0 # do not fail
+}
diff --git a/net-dns/ez-ipupdate/metadata.xml b/net-dns/ez-ipupdate/metadata.xml
new file mode 100644
index 000000000000..5160df8e893c
--- /dev/null
+++ b/net-dns/ez-ipupdate/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>sbriesen@gentoo.org</email>
+ <name>Stefan Briesenick</name>
+ </maintainer>
+ <longdescription lang="en">
+ Ez-ipupdate is a client for the dynamic IP service offered by
+ http://www.ez-ip.net. It has several options and is quite complete.
+ It is written in pure C and supports a daemon mode.
+ </longdescription>
+</pkgmetadata>