summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/gobby/gobby-0.4.93.ebuild')
-rw-r--r--app-editors/gobby/gobby-0.4.93.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-editors/gobby/gobby-0.4.93.ebuild b/app-editors/gobby/gobby-0.4.93.ebuild
new file mode 100644
index 000000000000..25bf4c37f273
--- /dev/null
+++ b/app-editors/gobby/gobby-0.4.93.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gobby/gobby-0.4.93.ebuild,v 1.1 2010/06/18 09:01:05 xarthisius Exp $
+
+EAPI="2"
+
+inherit base eutils
+
+DESCRIPTION="GTK-based collaborative editor"
+HOMEPAGE="http://gobby.0x539.de/"
+SRC_URI="http://releases.0x539.de/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0.5"
+KEYWORDS="~amd64"
+IUSE="avahi gnome"
+
+RDEPEND="dev-cpp/glibmm:2
+ dev-cpp/gtkmm:2.4
+ dev-libs/libsigc++:2
+ >=net-libs/libinfinity-0.4[gtk,avahi?]
+ dev-cpp/libxmlpp:2.6
+ x11-libs/gtksourceview:2.0
+ gnome? ( gnome-base/gnome-vfs )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+# There's only one test and it needs X
+RESTRICT="test"
+
+src_configure() {
+ econf $(use_with gnome)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ domenu contrib/gobby-0.5.desktop
+}