summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/haskell-mode/haskell-mode-2.3.ebuild')
-rw-r--r--app-emacs/haskell-mode/haskell-mode-2.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-emacs/haskell-mode/haskell-mode-2.3.ebuild b/app-emacs/haskell-mode/haskell-mode-2.3.ebuild
new file mode 100644
index 000000000000..6e165e1f4531
--- /dev/null
+++ b/app-emacs/haskell-mode/haskell-mode-2.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/haskell-mode/haskell-mode-2.3.ebuild,v 1.1 2007/02/14 21:41:35 opfer Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Mode for editing (and running) Haskell programs in Emacs"
+HOMEPAGE="http://www.haskell.org/haskell-mode/
+ http://www.iro.umontreal.ca/~monnier/elisp/"
+SRC_URI="http://www.iro.umontreal.ca/~monnier/elisp/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64 ~sparc"
+
+SITEFILE="51${PN}-gentoo.el"
+
+src_compile(){
+ emake || die "emake failed"
+}
+
+src_install() {
+ elisp-install ${PN} *.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dohtml *.html *.hs
+ dodoc ChangeLog NEWS README
+ insinto /usr/share/doc/${PF}
+ doins *.hs
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+ elog "See /usr/share/doc/${PF}/README"
+}