summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/magit/magit-1.1.1.ebuild')
-rw-r--r--app-emacs/magit/magit-1.1.1.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/app-emacs/magit/magit-1.1.1.ebuild b/app-emacs/magit/magit-1.1.1.ebuild
deleted file mode 100644
index d1820646d88b..000000000000
--- a/app-emacs/magit/magit-1.1.1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/magit/magit-1.1.1.ebuild,v 1.2 2012/11/26 11:31:15 ulm Exp $
-
-EAPI=4
-
-inherit elisp
-
-DESCRIPTION="An Emacs mode for GIT"
-HOMEPAGE="http://magit.github.com/magit/"
-SRC_URI="http://github.com/downloads/magit/magit/${P}.tar.gz"
-
-LICENSE="GPL-3+ FDL-1.2+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="contrib"
-
-SITEFILE="50magit-gentoo.el"
-
-src_compile() {
- emake core docs
- use contrib && emake contrib
-}
-
-src_install() {
- elisp-install ${PN} magit.{el,elc} \
- magit-{svn,topgit,stgit,key-mode,bisect}.{el,elc} || die
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
- doinfo magit.info
- dodoc README.md
-
- if use contrib; then
- elisp-install ${PN} contrib/*.{el,elc} || die
- dobin contrib/magit
- fi
-}