summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/php-mode/php-mode-1.2.0.ebuild')
-rw-r--r--app-emacs/php-mode/php-mode-1.2.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/php-mode/php-mode-1.2.0.ebuild b/app-emacs/php-mode/php-mode-1.2.0.ebuild
new file mode 100644
index 000000000000..ff49f51faf83
--- /dev/null
+++ b/app-emacs/php-mode/php-mode-1.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/php-mode/php-mode-1.2.0.ebuild,v 1.1 2007/02/09 08:32:37 opfer Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="GNU Emacs major mode for editing PHP code"
+HOMEPAGE="http://php-mode.sourceforge.net"
+SRC_URI="mirror://sourceforge/php-mode/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND=""
+
+S="${WORKDIR}"
+
+SITEFILE=50php-mode-gentoo.el
+
+src_compile() {
+ emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}