summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/lhs2tex/lhs2tex-1.11.ebuild')
-rw-r--r--dev-haskell/lhs2tex/lhs2tex-1.11.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-haskell/lhs2tex/lhs2tex-1.11.ebuild b/dev-haskell/lhs2tex/lhs2tex-1.11.ebuild
index c3f88610ef9b..2fc411db722c 100644
--- a/dev-haskell/lhs2tex/lhs2tex-1.11.ebuild
+++ b/dev-haskell/lhs2tex/lhs2tex-1.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/lhs2tex/lhs2tex-1.11.ebuild,v 1.6 2006/10/12 17:52:08 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/lhs2tex/lhs2tex-1.11.ebuild,v 1.7 2006/10/15 18:42:43 kosmikus Exp $
DESCRIPTION="Preprocessor for typesetting Haskell sources with LaTeX"
HOMEPAGE="http://www.iai.uni-bonn.de/~loeh/lhs2tex"
@@ -15,11 +15,15 @@ S="${WORKDIR}/${P/_pre/pre}"
DEPEND=">=dev-tex/polytable-0.8.2
>=virtual/ghc-6.2.2
- !>=virtual/ghc-6.6
doc? ( dev-lang/hugs98 virtual/tetex )"
RDEPEND=">=dev-tex/polytable-0.8.2"
+src_unpack() {
+ unpack ${A}
+ sed -i "s|-package lang||" ${S}/config.mk.in || die "patch failed"
+}
+
src_compile() {
# polytable is installed separately
econf --disable-polytable || die "econf failed"