summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/quickcheck/quickcheck-1.0.ebuild')
-rw-r--r--dev-haskell/quickcheck/quickcheck-1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-haskell/quickcheck/quickcheck-1.0.ebuild b/dev-haskell/quickcheck/quickcheck-1.0.ebuild
new file mode 100644
index 000000000000..a78b4a7dacb9
--- /dev/null
+++ b/dev-haskell/quickcheck/quickcheck-1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/quickcheck/quickcheck-1.0.ebuild,v 1.1 2007/03/11 16:59:34 kolmodin Exp $
+
+inherit ghc-package
+
+DESCRIPTION="An automatic, specification based testing utility for Haskell programs"
+HOMEPAGE="http://haskell.org/ghc/"
+SRC_URI=""
+LICENSE="BSD"
+SLOT="0"
+
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="=virtual/ghc-6.4*"
+
+pkg_setup () {
+ ghc-package_pkg_setup
+ einfo "This library is already provided by ghc. This ebuild does nothing."
+}
+
+src_install () {
+ dodir "$(ghc-libdir)"
+ touch "${D}/$(ghc-libdir)/.${P}.ghc-updater"
+}