summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libmemcached/libmemcached-0.35.ebuild')
-rw-r--r--dev-libs/libmemcached/libmemcached-0.35.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/libmemcached/libmemcached-0.35.ebuild b/dev-libs/libmemcached/libmemcached-0.35.ebuild
new file mode 100644
index 000000000000..a7bb3487de13
--- /dev/null
+++ b/dev-libs/libmemcached/libmemcached-0.35.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmemcached/libmemcached-0.35.ebuild,v 1.1 2009/11/24 06:24:22 robbat2 Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="a C client library to the memcached server"
+HOMEPAGE="http://tangent.org/552/libmemcached.html"
+SRC_URI="http://download.tangent.org/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~sparc-fbsd"
+IUSE="debug hsieh"
+
+DEPEND="net-misc/memcached"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.28-runtestsasuser.patch"
+}
+
+src_configure() {
+ econf \
+ $(use_with debug debug) \
+ $(use_enable hsieh hsieh_hash)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}
+
+src_test() {
+ cd tests || die "Tests failed"
+ emake testapp testplus library_test || die "Tests failed"
+}