summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/cpptest/cpptest-1.1.1.ebuild')
-rw-r--r--dev-util/cpptest/cpptest-1.1.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/cpptest/cpptest-1.1.1.ebuild b/dev-util/cpptest/cpptest-1.1.1.ebuild
new file mode 100644
index 000000000000..d5bc0c3054a9
--- /dev/null
+++ b/dev-util/cpptest/cpptest-1.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cpptest/cpptest-1.1.1.ebuild,v 1.1 2010/03/26 04:59:22 sping Exp $
+
+EAPI=2
+inherit autotools
+
+DESCRIPTION="Simple but powerful unit testing framework for C++"
+HOMEPAGE="http://cpptest.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.1.0-htmldir.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable doc) \
+ --htmldir=/usr/share/doc/${PF}/html/
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS BUGS NEWS README
+}