summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/diasce/diasce-1.4.ebuild')
-rw-r--r--dev-util/diasce/diasce-1.4.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-util/diasce/diasce-1.4.ebuild b/dev-util/diasce/diasce-1.4.ebuild
deleted file mode 100644
index f472389e1702..000000000000
--- a/dev-util/diasce/diasce-1.4.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/diasce/diasce-1.4.ebuild,v 1.13 2008/02/04 20:59:08 armin76 Exp $
-
-inherit eutils
-
-MY_P=${PN}2-${PV}
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="The C/C++ Code editor for Gnome"
-HOMEPAGE="http://diasce.sourceforge.net/"
-SRC_URI="mirror://sourceforge/diasce/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc x86"
-IUSE="nls"
-
-RDEPEND=">=dev-libs/libxml2-2.4
- >=x11-libs/gtk+-2
- >=dev-libs/glib-2
- >=gnome-base/libglade-2
- >=gnome-base/libgnome-2
- >=gnome-base/libgnomeui-2
- >=gnome-base/libbonobo-2
- >=gnome-base/libbonoboui-2
- >=gnome-base/gnome-vfs-2
- >=gnome-base/gconf-1.2
- >=gnome-base/libgnomecanvas-2
- >=gnome-base/libgnomeprintui-2"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- >=gnome-base/orbit-2.8
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-linc.patch
-}
-
-src_compile() {
- local myconf=""
-
- myconf="${myconf} `use_enable nls`"
-
- econf ${myconf} || die "./configure failed"
- emake || die "emake failed"
-}
-
-src_install() {
- einstall || die "einstall failed"
- dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
-}