summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/mutantstorm-demo')
-rw-r--r--games-action/mutantstorm-demo/ChangeLog20
-rw-r--r--games-action/mutantstorm-demo/files/digest-mutantstorm-demo-1.331
-rw-r--r--games-action/mutantstorm-demo/metadata.xml41
-rw-r--r--games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild41
4 files changed, 103 insertions, 0 deletions
diff --git a/games-action/mutantstorm-demo/ChangeLog b/games-action/mutantstorm-demo/ChangeLog
new file mode 100644
index 000000000000..b7d081dfc9a6
--- /dev/null
+++ b/games-action/mutantstorm-demo/ChangeLog
@@ -0,0 +1,20 @@
+# ChangeLog for games-action/mutantstormdemo
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/mutantstorm-demo/ChangeLog,v 1.1 2004/05/12 21:44:18 wolf31o2 Exp $
+
+ 12 May 2004; Chris Gianelloni <wolf31o2@gentoo.org> :
+ Moved from mutantstormdemo to mutantstorm-demo to match naming conventions.
+
+ 19 Apr 2004; Chris Gianelloni <wolf31o2@gentoo.org>
+ mutantstormdemo-1.33.ebuild:
+ Added IUSE.
+
+*mutantstormdemo-1.33 (07 Oct 2003)
+
+ 07 Oct 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bumpage.
+
+*mutantstormdemo-1 (07 Jul 2003)
+
+ 07 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/games-action/mutantstorm-demo/files/digest-mutantstorm-demo-1.33 b/games-action/mutantstorm-demo/files/digest-mutantstorm-demo-1.33
new file mode 100644
index 000000000000..241e2d1dc0dd
--- /dev/null
+++ b/games-action/mutantstorm-demo/files/digest-mutantstorm-demo-1.33
@@ -0,0 +1 @@
+MD5 63aa5595bd04eeef5bd789fc782db122 MutantStormDemo_1_33.sh.bin 9249167
diff --git a/games-action/mutantstorm-demo/metadata.xml b/games-action/mutantstorm-demo/metadata.xml
new file mode 100644
index 000000000000..c35315b4ed36
--- /dev/null
+++ b/games-action/mutantstorm-demo/metadata.xml
@@ -0,0 +1,41 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+ <email>vapier@gentoo.org</email>
+ <name>Mike Frysinger</name>
+</maintainer>
+<longdescription>
+Mutant Storm progresses over 89 levels of psychedelic 3D arenas, that get
+ever more crowded with nasty beasties. This carnival of frenetic fun is
+showcased in a cutting edge graphics extravganza.
+
+Viewed from well above, you and your enemies can always be seen. Always be
+killed, and always be laughed at! There is no hiding. No tactics. No
+planning... No Net.
+Your enemies created this world and they sure ain't gonna help you
+out!
+
+You like to play hard? Then the game gets harder. Feel like your doing
+well? ...
+Enjoy it while it lasts!
+
+Survive long enough, and you get rewarded with score multipliers, doubling
+your score. Making your enemies even angrier, and that bit more determined
+to kill you!
+Lose a life and watch your multipliers tumble, and the beasties slow down
+and relax, safe in the knowledge that you are just a big softy really!!
+After you conquer all 89 levels you'll be awarded your first
+'White Belt' progressing if you can win all 8 belts until you
+have possess the much coveted Mutant Storm 'Black Belt'.
+
+Mutant Storm is inspired the classic RoboTron by Williams, Smash TV and
+Jeff Minters fantastic Llamatron.
+To those unacquainted, this means one hand controlling fire direction, and
+the other controlling movement. Sounds confusing? ...don't worry, just grab
+your trusty mouse ( or dual stick joypad if you want genuine Robotron style
+) and give it a go. Its very simple once you try, and very intuitive once
+you're used to it.
+</longdescription>
+</pkgmetadata>
diff --git a/games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild b/games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild
new file mode 100644
index 000000000000..b479352941a3
--- /dev/null
+++ b/games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/mutantstorm-demo/mutantstorm-demo-1.33.ebuild,v 1.1 2004/05/12 21:44:18 wolf31o2 Exp $
+
+inherit games eutils
+
+DESCRIPTION="shoot through crazy psychedelic 3D environments"
+HOMEPAGE="http://www.pompom.org.uk/"
+SRC_URI="ftp://ggdev-1.homelan.com/mutantstorm/MutantStormDemo_${PV/./_}.sh.bin"
+
+LICENSE="POMPOM"
+SLOT="0"
+KEYWORDS="-* x86"
+IUSE=""
+
+S=${WORKDIR}
+
+pkg_setup() {
+ check_license
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+ dodir ${dir} ${GAMES_BINDIR}
+
+ cp -r menu script styles ${D}/${dir}/
+
+ exeinto ${dir}
+ doexe bin/Linux/x86/*
+ dosym ${dir}/mutantstormdemo ${GAMES_BINDIR}/mutantstorm-demo
+
+ insinto ${dir}
+ doins README.txt buy_me mutant.xpm pompom readme.htm
+
+ prepgamesdirs
+}