summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/ut2004')
-rw-r--r--games-fps/ut2004/ChangeLog11
-rw-r--r--games-fps/ut2004/Manifest16
-rw-r--r--games-fps/ut2004/files/digest-ut2004-3355-r22
-rw-r--r--games-fps/ut2004/ut2004-3355-r2.ebuild155
4 files changed, 171 insertions, 13 deletions
diff --git a/games-fps/ut2004/ChangeLog b/games-fps/ut2004/ChangeLog
index 45dd717182be..4c3d5d73f048 100644
--- a/games-fps/ut2004/ChangeLog
+++ b/games-fps/ut2004/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for games-fps/ut2004
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004/ChangeLog,v 1.26 2005/07/27 09:50:40 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004/ChangeLog,v 1.27 2005/08/03 16:03:59 wolf31o2 Exp $
+
+*ut2004-3355-r2 (03 Aug 2005)
+
+ 03 Aug 2005; Chris Gianelloni <wolf31o2@gentoo.org>
+ +ut2004-3355-r2.ebuild:
+ Added experimental version for testing. This should look visually much
+ better on x86. The amd64 version will come in an official patch based on
+ feedback from this test, so please test this and report any bugs to
+ https://bugzilla.icculus.org so it can be fixed.
27 Jul 2005; Jeremy Huddleston <eradicator@gentoo.org>
ut2004-3355-r1.ebuild:
diff --git a/games-fps/ut2004/Manifest b/games-fps/ut2004/Manifest
index bfec58f3f44e..65c9efc3ab79 100644
--- a/games-fps/ut2004/Manifest
+++ b/games-fps/ut2004/Manifest
@@ -1,17 +1,9 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 78dbd4e5e8bc61209ac16991a10e2648 ChangeLog 4363
+MD5 6b5300be29674c24155d224cf813e53a ChangeLog 4742
MD5 11a7e1491b1ac042ac7216b26b4ad1fb metadata.xml 254
MD5 072ff8cd5c9bbf3951842ed77c245c5b ut2004-3355.ebuild 3095
MD5 d782048ef1ad865d4b234f1eaa6176ed ut2004-3355-r1.ebuild 3296
-MD5 e199cda0f458ab3a4b3ca2e482451c8f files/ut2004.xml 358
+MD5 8e56b33645cc1d5ba535f7648746460b ut2004-3355-r2.ebuild 4703
MD5 8301dab70fc9c57363f99591c5944b63 files/digest-ut2004-3355 74
+MD5 e199cda0f458ab3a4b3ca2e482451c8f files/ut2004.xml 358
MD5 3953d9c3f549c05431bb62a8df17a787 files/digest-ut2004-3355-r1 153
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFC51kGArHZZzCEUG0RAprSAJwN2PYJ70eYBuOa/aTe9ik5zNG8nQCggMDD
-IoMOHJjHoRK1rFvJrf5yPXg=
-=ycxU
------END PGP SIGNATURE-----
+MD5 e02d7893c2788aa939dfb8896c0cc3b3 files/digest-ut2004-3355-r2 162
diff --git a/games-fps/ut2004/files/digest-ut2004-3355-r2 b/games-fps/ut2004/files/digest-ut2004-3355-r2
new file mode 100644
index 000000000000..a41761a1c7bd
--- /dev/null
+++ b/games-fps/ut2004/files/digest-ut2004-3355-r2
@@ -0,0 +1,2 @@
+MD5 379198183e16cefeb585a1c3252e63dd ut2004-lnxpatch3355.tar.bz2 20655315
+MD5 bc5ff36eeb1bbdf0e9593fa80167b804 ut2004-lnx-3355-with-rendertargets.tar.bz2 4514586
diff --git a/games-fps/ut2004/ut2004-3355-r2.ebuild b/games-fps/ut2004/ut2004-3355-r2.ebuild
new file mode 100644
index 000000000000..7298e47d7ebf
--- /dev/null
+++ b/games-fps/ut2004/ut2004-3355-r2.ebuild
@@ -0,0 +1,155 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004/ut2004-3355-r2.ebuild,v 1.1 2005/08/03 16:03:59 wolf31o2 Exp $
+
+inherit eutils games
+
+MY_P="${PN}-lnxpatch${PV}.tar.bz2"
+DESCRIPTION="Unreal Tournament 2004 - Editor's Choice Edition"
+HOMEPAGE="http://www.unrealtournament2004.com/"
+SRC_URI="mirror://3dgamers/pub/3dgamers/games/unrealtourn2k4/${MY_P}
+ http://speculum.twistedgamer.com/pub/0day.icculus.org/${PN}/${MY_P}
+ experimental? ( http://icculus.org/~icculus/tmp/${PN}-lnx-${PV}-with-rendertargets.tar.bz2 )"
+
+LICENSE="ut2003"
+SLOT="0"
+KEYWORDS="~x86"
+RESTRICT="nostrip nomirror"
+IUSE="opengl dedicated experimental"
+
+RDEPEND="games-fps/ut2004-data
+ games-fps/ut2004-bonuspack-ece
+ opengl? ( virtual/opengl )
+ dedicated? ( app-misc/screen )"
+
+S=${WORKDIR}/UT2004-Patch
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+pkg_setup() {
+ check_license || die "License check failed"
+ if use experimental
+ then
+ ewarn "You are enabling support for an experimental patch from icculus."
+ ewarn "This patch solves some missing issues with the Linux version of"
+ ewarn "the game. Please report all bugs you find with this version to"
+ ewarn "https://bugzilla.icculus.org"
+ ebeep
+ epause
+ fi
+ games_pkg_setup
+}
+
+src_install() {
+ # moving patched binary into proper location
+ use experimental && mv -f ${WORKDIR}/ut2004-bin ${S}/System
+
+ # Installing patch files
+ for p in {Animations,Help,Speech,System,Textures,Web}
+ do
+ dodir ${dir}/${p}
+ cp -r ${S}/${p}/* ${Ddir}/${p} \
+ || die "copying ${p} from patch"
+ done
+
+ use amd64 && rm ${Ddir}/System/u{cc,t2004}-bin \
+ && mv ${Ddir}/System/ucc-bin-linux-amd64 ${Ddir}/System/ucc-bin \
+ && mv ${Ddir}/System/ut2004-bin-linux-amd64 ${Ddir}/System/ut2004-bin \
+ && chmod ug+x ${Ddir}/System/ucc-bin ${Ddir}/System/ut2004-bin
+ use x86 && rm ${Ddir}/System/ucc-bin-linux-amd64 \
+ ${Ddir}/System/ut2004-bin-linux-amd64
+
+ # creating .manifest files
+ insinto ${dir}/.manifest
+ doins ${FILESDIR}/${PN}.xml
+
+ # creating .loki/installed links
+ mkdir -p ${D}/root/.loki/installed
+ dosym ${dir}/.manifest/${PN}.xml ${ROOT}/root/.loki/installed/${PN}.xml
+
+ # Here we edit the Default.ini to enable support for the experimentla patch
+ if use experimental
+ then
+ ed ${Ddir}/System/Default.ini >/dev/null 2>&1 <<EOT
+$
+?OpenGLDrv.OpenGLRenderDevice?
+a
+UseRenderTargets=True
+.
+w
+q
+EOT
+ sed -i -e 's/bPlayerShadows=False/bPlayerShadows=True/' \
+ -e 's/bBlobShadow=True/bBlobShadow=False/' \
+ -e 's/bVehicleShadows=False/bVehicleShadows=True/' \
+ ${Ddir}/System/DefUser.ini
+ fi
+
+ games_make_wrapper ut2004 ./ut2004 ${dir}
+
+ prepgamesdirs
+ make_desktop_entry ut2004 "Unreal Tournament 2004" ut2004.xpm
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ # here is where we check for the existence of a cdkey...
+ # if we don't find one, we ask the user for it
+ if [ -f ${dir}/System/cdkey ]; then
+ einfo "A cdkey file is already present in ${dir}/System"
+ else
+ ewarn "You MUST run this before playing the game:"
+ ewarn "ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config"
+ ewarn "That way you can [re]enter your cdkey."
+ fi
+ echo
+ einfo "To play the game run:"
+ einfo " ut2004"
+ echo
+ if use experimental
+ then
+ ewarn "If you are not installing for the first time and wish to test"
+ ewarn "the new Render to Texture patch, then you will probably need to"
+ ewarn "edit your ~/.ut2004/System/UT2004.ini file and add a line that"
+ ewarn "says UseRenderTargets=True to your"
+ ewarn "[OpenGLDrv.OpenGLRenderDevice] section. You will also need to"
+ ewarn "edit your ~/.ut2004/System/User.ini file and make sure that you"
+ ewarn "have bPlayerShadows=True and bBlobShadow=False in your"
+ ewarn "[UnrealGame.UnrealPawn] section. Also, be sure to set"
+ ewarn "bVehicleShadows=True in your [Engine.Vehicle] section."
+ ebeep
+ epause
+ fi
+}
+
+pkg_postrm() {
+ ewarn "This package leaves a cdkey file in ${dir}/System that you need"
+ ewarn "to remove to completely get rid of this game's files."
+}
+
+pkg_config() {
+ ewarn "Your CD key is NOT checked for validity here."
+ ewarn " Make sure you type it in correctly."
+ eerror "If you CTRL+C out of this, the game will not run!"
+ echo
+ einfo "CD key format is: XXXXX-XXXXX-XXXXX-XXXXX"
+ while true ; do
+ einfo "Please enter your CD key:"
+ read CDKEY1
+ einfo "Please re-enter your CD key:"
+ read CDKEY2
+ if [ "$CDKEY1" == "" ] ; then
+ echo "You entered a blank CD key. Try again."
+ else
+ if [ "$CDKEY1" == "$CDKEY2" ] ; then
+ echo "$CDKEY1" | tr a-z A-Z > ${dir}/System/cdkey
+ einfo "Thank you!"
+ break
+ else
+ eerror "Your CD key entries do not match. Try again."
+ fi
+ fi
+ done
+}