summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/industri/ChangeLog7
-rw-r--r--games-fps/industri/industri-1.01.ebuild19
-rw-r--r--games-fps/rott/ChangeLog5
-rw-r--r--games-fps/rott/rott-1.0.ebuild23
-rw-r--r--games-fps/wolfgl/ChangeLog6
-rw-r--r--games-fps/wolfgl/wolfgl-0.93-r1.ebuild31
6 files changed, 54 insertions, 37 deletions
diff --git a/games-fps/industri/ChangeLog b/games-fps/industri/ChangeLog
index dc8687ec9729..b04c8976e12f 100644
--- a/games-fps/industri/ChangeLog
+++ b/games-fps/industri/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-fps/industri
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/industri/ChangeLog,v 1.3 2004/06/25 03:23:01 agriffis Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/industri/ChangeLog,v 1.4 2005/09/16 01:17:11 mr_bones_ Exp $
+
+ 16 Sep 2005; Michael Sterrett <mr_bones_@gentoo.org> industri-1.01.ebuild:
+ needs app-arch/unzip; tidy
03 Jun 2004; Aron Griffis <agriffis@gentoo.org> industri-1.01.ebuild:
Fix use invocation
diff --git a/games-fps/industri/industri-1.01.ebuild b/games-fps/industri/industri-1.01.ebuild
index 4bde393219fd..d064d6096038 100644
--- a/games-fps/industri/industri-1.01.ebuild
+++ b/games-fps/industri/industri-1.01.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/industri/industri-1.01.ebuild,v 1.8 2005/06/13 00:39:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/industri/industri-1.01.ebuild,v 1.9 2005/09/16 01:17:11 mr_bones_ Exp $
-inherit games toolchain-funcs
+inherit toolchain-funcs games
DESCRIPTION="Quake/Tenebrae based, single player game"
HOMEPAGE="http://industri.sourceforge.net/"
@@ -14,10 +14,12 @@ SLOT="0"
KEYWORDS="x86"
IUSE=""
-DEPEND="virtual/opengl
+RDEPEND="virtual/opengl
virtual/x11
media-libs/libpng
sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
S=${WORKDIR}/industri_BIN
@@ -26,7 +28,7 @@ src_unpack() {
cd "${S}"/linux
mv Makefile.i386linux Makefile
- sed -i "s:-mpentiumpro.*:${CFLAGS} \\\\:" Makefile
+ sed -i -e "s:-mpentiumpro.*:${CFLAGS} \\\\:" Makefile || die "sed failed"
# Remove duplicated typedefs #71841
cd "${S}"
@@ -34,14 +36,15 @@ src_unpack() {
if echo '#include <GL/gl.h>' | $(tc-getCC) -E - 2>/dev/null | grep -sq ${typ} ; then
sed -i \
-e "/^typedef.*${typ}/d" \
- glquake.h
+ glquake.h \
+ || die "sed failed"
fi
done
}
src_compile() {
- cd linux
- emake MASTER_DIR=${GAMES_DATADIR}/quake-data build_release || die
+ emake -C linux MASTER_DIR="${GAMES_DATADIR}"/quake-data build_release \
+ || die "emake failed"
}
src_install() {
@@ -52,7 +55,7 @@ src_install() {
dodoc linux/README
cd "${WORKDIR}"/industri
dodoc *.txt && rm *.txt
- insinto ${GAMES_DATADIR}/quake-data/industri
+ insinto "${GAMES_DATADIR}"/quake-data/industri
doins *
prepgamesdirs
}
diff --git a/games-fps/rott/ChangeLog b/games-fps/rott/ChangeLog
index 2d7c820f6c28..86bf957bbb23 100644
--- a/games-fps/rott/ChangeLog
+++ b/games-fps/rott/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-fps/rott
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/rott/ChangeLog,v 1.4 2005/01/05 14:12:30 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/rott/ChangeLog,v 1.5 2005/09/16 01:19:49 mr_bones_ Exp $
+
+ 16 Sep 2005; Michael Sterrett <mr_bones_@gentoo.org> rott-1.0.ebuild:
+ needs app-arch/unzip; tidy
05 Jan 2005; <avatar@gentoo.org> rott-1.0.ebuild:
Added to ~ppc.
diff --git a/games-fps/rott/rott-1.0.ebuild b/games-fps/rott/rott-1.0.ebuild
index 26a66272dde2..2a5ee9b44053 100644
--- a/games-fps/rott/rott-1.0.ebuild
+++ b/games-fps/rott/rott-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/rott/rott-1.0.ebuild,v 1.6 2005/01/05 14:12:30 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/rott/rott-1.0.ebuild,v 1.7 2005/09/16 01:19:49 mr_bones_ Exp $
inherit eutils games
@@ -11,32 +11,33 @@ SRC_URI="http://www.icculus.org/rott/releases/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ~ppc"
+KEYWORDS="~ppc x86"
IUSE=""
-DEPEND="media-libs/libsdl
+RDEPEND="media-libs/libsdl
media-libs/sdl-mixer"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
S=${WORKDIR}/${P}/rott
src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/${PV}-custom-datapath.patch
+ epatch "${FILESDIR}"/${PV}-custom-datapath.patch
}
src_compile() {
make clean || die
- make EXTRACFLAGS="${CFLAGS} -DDATADIR=\\\"${GAMES_DATADIR}/${PN}/\\\"" || die
+ emake -j1 EXTRACFLAGS="${CFLAGS} -DDATADIR=\\\"${GAMES_DATADIR}/${PN}/\\\"" \
+ || die "emake failed"
}
src_install() {
- dogamesbin rott
+ dogamesbin rott || die "dogamesbin failed"
dodoc *.txt ../{README,readme.txt}
-
- cd ${WORKDIR}
- insinto ${GAMES_DATADIR}/${PN}
- doins *.dmo huntbgin.* remote1.rts
-
+ cd "${WORKDIR}"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins *.dmo huntbgin.* remote1.rts || die "doins failed"
prepgamesdirs
}
diff --git a/games-fps/wolfgl/ChangeLog b/games-fps/wolfgl/ChangeLog
index 79fb3074dd2d..31c295a62612 100644
--- a/games-fps/wolfgl/ChangeLog
+++ b/games-fps/wolfgl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/wolfgl
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/wolfgl/ChangeLog,v 1.5 2005/06/10 13:08:55 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/wolfgl/ChangeLog,v 1.6 2005/09/16 01:22:23 mr_bones_ Exp $
+
+ 16 Sep 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ wolfgl-0.93-r1.ebuild:
+ needs app-arch/unzip; tidy
10 Jun 2005; David Holm <dholm@gentoo.org> wolfgl-0.93-r1.ebuild:
Added to ~ppc.
diff --git a/games-fps/wolfgl/wolfgl-0.93-r1.ebuild b/games-fps/wolfgl/wolfgl-0.93-r1.ebuild
index d370ff6c123c..dd0968c5d291 100644
--- a/games-fps/wolfgl/wolfgl-0.93-r1.ebuild
+++ b/games-fps/wolfgl/wolfgl-0.93-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/wolfgl/wolfgl-0.93-r1.ebuild,v 1.4 2005/06/10 13:08:55 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/wolfgl/wolfgl-0.93-r1.ebuild,v 1.5 2005/09/16 01:22:23 mr_bones_ Exp $
#ECVS_SERVER="cvs.sourceforge.net:/cvsroot/wolfgl"
#ECVS_MODULE="wolfgl"
@@ -15,33 +15,36 @@ SRC_URI="mirror://gentoo/${P}.tbz2
# mirror://sourceforge/wolfgl/wolfglx-wl6-${PV}.zip
# mirror://sourceforge/wolfgl/wolfglx-sod-${PV}.zip
-KEYWORDS="~ppc x86"
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="~ppc x86"
IUSE=""
-DEPEND="virtual/opengl
+RDEPEND="virtual/opengl
virtual/x11"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PV}-gcc.patch
- epatch ${FILESDIR}/${PV}-sample-rate.patch
- epatch ${FILESDIR}/${PV}-sprite.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-gcc.patch \
+ "${FILESDIR}"/${PV}-sample-rate.patch \
+ "${FILESDIR}"/${PV}-sprite.patch
}
src_compile() {
- make CFLAGS="${CFLAGS}" DATADIR=${GAMES_DATADIR}/${PN} || die
+ emake -j1 CFLAGS="${CFLAGS}" DATADIR="${GAMES_DATADIR}"/${PN} \
+ || die "emake failed"
}
src_install() {
- newgamesbin linux/SDM/wolfgl wolfgl-sdm
- newgamesbin linux/SOD/wolfgl wolfgl-sod
- newgamesbin linux/WL1/wolfgl wolfgl-wl1
- newgamesbin linux/WL6/wolfgl wolfgl-wl6
- insinto ${GAMES_DATADIR}/${PN}
- doins ${WORKDIR}/*.{sdm,wl1}
+ newgamesbin linux/SDM/wolfgl wolfgl-sdm || die
+ newgamesbin linux/SOD/wolfgl wolfgl-sod || die
+ newgamesbin linux/WL1/wolfgl wolfgl-wl1 || die
+ newgamesbin linux/WL6/wolfgl wolfgl-wl6 || die
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins "${WORKDIR}"/*.{sdm,wl1} || die
prepgamesdirs
}