summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/gconf/gconf-2.26.0.ebuild')
-rw-r--r--gnome-base/gconf/gconf-2.26.0.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnome-base/gconf/gconf-2.26.0.ebuild b/gnome-base/gconf/gconf-2.26.0.ebuild
index 06c9c4167211..daf9ef793646 100644
--- a/gnome-base/gconf/gconf-2.26.0.ebuild
+++ b/gnome-base/gconf/gconf-2.26.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.26.0.ebuild,v 1.1 2009/04/19 07:26:06 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.26.0.ebuild,v 1.2 2009/05/01 11:39:25 eva Exp $
inherit autotools eutils gnome2
@@ -14,7 +14,7 @@ SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
LICENSE="LGPL-2"
SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc64 ~sh ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="debug doc ldap policykit"
RDEPEND=">=dev-libs/glib-2.14
@@ -44,6 +44,9 @@ pkg_setup() {
$(use_with ldap openldap)
$(use_enable policykit defaults-service)"
kill_gconf
+
+ # Need host's IDL compiler for cross or native build, bug #262747
+ export EXTRA_EMAKE="${EXTRA_EMAKE} ORBIT_IDL=/usr/bin/orbit-idl-2"
}
src_unpack() {
@@ -69,6 +72,8 @@ src_install() {
keepdir /etc/gconf/gconf.xml.mandatory
keepdir /etc/gconf/gconf.xml.defaults
+ # Make sure this directory exists, bug #268070, upstream #572027
+ keepdir /etc/gconf/gconf.xml.system
echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > 50gconf
doenvd 50gconf || die "doenv failed"