summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kpilot')
-rw-r--r--kde-base/kpilot/ChangeLog7
-rw-r--r--kde-base/kpilot/files/digest-kpilot-3.5.43
-rw-r--r--kde-base/kpilot/kpilot-3.5.4.ebuild37
3 files changed, 46 insertions, 1 deletions
diff --git a/kde-base/kpilot/ChangeLog b/kde-base/kpilot/ChangeLog
index 8c174716d97c..6aeaf0062c9f 100644
--- a/kde-base/kpilot/ChangeLog
+++ b/kde-base/kpilot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kpilot
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/ChangeLog,v 1.39 2006/06/01 19:36:58 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/ChangeLog,v 1.40 2006/07/25 07:31:11 flameeyes Exp $
+
+*kpilot-3.5.4 (25 Jul 2006)
+
+ 25 Jul 2006; Diego Pettenò <flameeyes@gentoo.org> +kpilot-3.5.4.ebuild:
+ Bump to 3.5.4 (pre-release).
*kpilot-3.5.3 (01 Jun 2006)
diff --git a/kde-base/kpilot/files/digest-kpilot-3.5.4 b/kde-base/kpilot/files/digest-kpilot-3.5.4
new file mode 100644
index 000000000000..1b21946a4916
--- /dev/null
+++ b/kde-base/kpilot/files/digest-kpilot-3.5.4
@@ -0,0 +1,3 @@
+MD5 4a01ceaeb6067d03003edb77b104f559 kdepim-3.5.4.tar.bz2 12925075
+RMD160 d3ecf9353dc578c392e1b82c72c7b8a2a88fdcdc kdepim-3.5.4.tar.bz2 12925075
+SHA256 b31dee9c2d7ebdeb1841c22dbdeaf1c88ee1f0d3b11897592305ec076d02edfa kdepim-3.5.4.tar.bz2 12925075
diff --git a/kde-base/kpilot/kpilot-3.5.4.ebuild b/kde-base/kpilot/kpilot-3.5.4.ebuild
new file mode 100644
index 000000000000..d4a448224b0d
--- /dev/null
+++ b/kde-base/kpilot/kpilot-3.5.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/kpilot-3.5.4.ebuild,v 1.1 2006/07/25 07:31:11 flameeyes Exp $
+
+KMNAME=kdepim
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KPilot - HotSync software for KDE"
+KEYWORDS="~amd64"
+IUSE=""
+DEPEND="app-pda/pilot-link
+ dev-libs/libmal
+$(deprange $PV $MAXKDEVER kde-base/libkcal)
+$(deprange $PV $MAXKDEVER kde-base/libkdepim)
+$(deprange $PV $MAXKDEVER kde-base/kontact)"
+
+KMCOPYLIB="
+ libkcal libkcal
+ libkdepim libkdepim
+ libkpinterfaces kontact/interfaces"
+# libkcal is installed because a lot of headers are needed, but it don't have to be compiled
+KMEXTRACTONLY="
+ libkcal/
+ libkdepim libkdepim/
+ kontact/interfaces/"
+KMEXTRA="
+ kfile-plugins/palm-databases
+ kontact/plugins/kpilot/" # We add here the kontact's plugin instead of compiling it with kontact because it needs a lot of this programs deps.
+
+src_compile() {
+ # needed to detect pi-notepad.h, used by the kpilot notepad conduit.
+ myconf="${myconf} --with-extra-includes=/usr/include/libpisock"
+
+ kde-meta_src_compile
+}