summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/trojita/trojita-0.3.92.ebuild')
-rw-r--r--mail-client/trojita/trojita-0.3.92.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/mail-client/trojita/trojita-0.3.92.ebuild b/mail-client/trojita/trojita-0.3.92.ebuild
new file mode 100644
index 000000000000..35e603936a9f
--- /dev/null
+++ b/mail-client/trojita/trojita-0.3.92.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/trojita/trojita-0.3.92.ebuild,v 1.1 2013/02/28 12:22:25 ago Exp $
+
+EAPI=4
+
+QT_REQUIRED="4.6.0"
+EGIT_REPO_URI="git://gitorious.org/${PN}/${PN}.git"
+[[ ${PV} == "9999" ]] && GIT_ECLASS="git-2"
+inherit qt4-r2 virtualx ${GIT_ECLASS}
+
+DESCRIPTION="A Qt IMAP e-mail client"
+HOMEPAGE="http://trojita.flaska.net/"
+if [[ ${PV} == "9999" ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~x86"
+ MY_LANGS="bs cs de es et ga gl hu ia lt nl pl pt pt_BR sk sv tr uk zh_CN zh_TW"
+fi
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+IUSE="debug test +zlib"
+for MY_LANG in ${MY_LANGS} ; do
+ IUSE="${IUSE} linguas_${MY_LANG}"
+done
+
+RDEPEND="
+ >=x11-libs/qt-gui-${QT_REQUIRED}:4
+ >=x11-libs/qt-sql-${QT_REQUIRED}:4[sqlite]
+ >=x11-libs/qt-webkit-${QT_REQUIRED}:4
+"
+DEPEND="${RDEPEND}
+ test? ( >=x11-libs/qt-test-${QT_REQUIRED}:4 )
+ zlib? (
+ virtual/pkgconfig
+ sys-libs/zlib
+ )
+"
+
+src_configure() {
+ local myopts=""
+ use debug && myopts="$myopts CONFIG+=debug"
+ use test || myopts="$myopts CONFIG+=disable_tests"
+ use zlib || myopts="$myopts CONFIG+=disable_zlib"
+ if [[ ${MY_LANGS} ]]; then
+ rm po/trojita_common_x-test.po
+ for x in po/*.po; do
+ mylang=${x#po/trojita_common_}
+ mylang=${mylang%.po}
+ use linguas_$mylang || rm $x
+ done
+ fi
+
+ eqmake4 PREFIX=/usr $myopts
+}
+
+src_test() {
+ Xemake test
+}