summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/ffmpeg/ffmpeg-0.4.7_pre20030624.ebuild')
-rw-r--r--media-video/ffmpeg/ffmpeg-0.4.7_pre20030624.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/media-video/ffmpeg/ffmpeg-0.4.7_pre20030624.ebuild b/media-video/ffmpeg/ffmpeg-0.4.7_pre20030624.ebuild
index f22862d5dc98..78bb403ceb2e 100644
--- a/media-video/ffmpeg/ffmpeg-0.4.7_pre20030624.ebuild
+++ b/media-video/ffmpeg/ffmpeg-0.4.7_pre20030624.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-0.4.7_pre20030624.ebuild,v 1.1 2003/06/26 18:29:12 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-0.4.7_pre20030624.ebuild,v 1.2 2003/07/02 18:13:25 raker Exp $
+
+inherit eutils
DESCRIPTION="Complete solution to record, convert and stream audio and video. Includes libavcodec."
SRC_URI="mirror://gentoo/ffmpeg-cvs-2003-06-24.tar.gz"
@@ -28,6 +30,11 @@ S=${WORKDIR}/ffmpeg-cvs-2003-06-24
src_unpack() {
unpack ${A} || die
cd ${S}
+
+ # fixes a compile on alpha. This is fixed in upstream cvs
+ # http://cvs.sourceforge.net/cgi-bin/viewcvs.cgi/ffmpeg/ffmpeg/libavcodec/alpha/dsputil_alpha.c.diff?r1=1.19&r2=1.20
+ # so this patch should be removed with the next _pre build
+ epatch ${FILESDIR}/alpha-idct.patch
}
src_compile() {