summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-28 00:05:38 +0000
committerSam James <sam@gentoo.org>2022-12-28 00:32:14 +0000
commit8ee8f63ef9313e478246cffcd855f0d5e73bc962 (patch)
tree9940612e034a40b1994a3eecbbb86a964cac1d40 /app-arch/pigz/pigz-2.6.ebuild
parentapp-arch/gzip: drop 1.12-r2 (diff)
downloadgentoo-8ee8f63ef9313e478246cffcd855f0d5e73bc962.tar.gz
gentoo-8ee8f63ef9313e478246cffcd855f0d5e73bc962.tar.bz2
gentoo-8ee8f63ef9313e478246cffcd855f0d5e73bc962.zip
app-arch/pigz: drop 2.6
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch/pigz/pigz-2.6.ebuild')
-rw-r--r--app-arch/pigz/pigz-2.6.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/app-arch/pigz/pigz-2.6.ebuild b/app-arch/pigz/pigz-2.6.ebuild
deleted file mode 100644
index 94c255643611..000000000000
--- a/app-arch/pigz/pigz-2.6.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs flag-o-matic
-
-DESCRIPTION="A parallel implementation of gzip"
-HOMEPAGE="https://www.zlib.net/pigz/"
-SRC_URI="https://www.zlib.net/pigz/${P}.tar.gz"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~ppc-macos ~sparc64-solaris"
-IUSE="static symlink test"
-RESTRICT="!test? ( test )"
-
-LIB_DEPEND="sys-libs/zlib[static-libs(+)]"
-RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
-DEPEND="${RDEPEND}
- static? ( ${LIB_DEPEND} )
- test? ( app-arch/ncompress )"
-
-src_compile() {
- use static && append-ldflags -static
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
-}
-
-src_install() {
- dobin ${PN}
- dosym ${PN} /usr/bin/un${PN}
- dodoc README
- doman ${PN}.1
-
- if use symlink; then
- dosym ${PN} /usr/bin/gzip
- dosym un${PN} /usr/bin/gunzip
- fi
-}