summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tex/lgrind
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tex/lgrind')
-rw-r--r--dev-tex/lgrind/Manifest1
-rw-r--r--dev-tex/lgrind/files/lgrind-3.67-fgets.patch13
-rw-r--r--dev-tex/lgrind/lgrind-3.67-r3.ebuild50
-rw-r--r--dev-tex/lgrind/metadata.xml5
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-tex/lgrind/Manifest b/dev-tex/lgrind/Manifest
new file mode 100644
index 000000000000..aad4be4c58f6
--- /dev/null
+++ b/dev-tex/lgrind/Manifest
@@ -0,0 +1 @@
+DIST lgrind.tar.gz 73205 SHA256 234642885100c7e6ddb2be734d652252defd4ccd5d5ae6ef7fc6b56ebbb5b847 SHA512 89dffec60b6cbac82e9633690412961cb619d6d86d39bea2fb6f3026e1317eb00494d7ed68865a943b1872346eaecdc1b8502de41517023a47309e1e803da2c6 WHIRLPOOL f37a086a6ffeb40e6de1105d5fdb715de3d5eb0b5769a9cafc46d569edabbaa7776df187b9710c6b88548adaaafead1bde630ef6671ff7a4c6af3ff4c4b014f7
diff --git a/dev-tex/lgrind/files/lgrind-3.67-fgets.patch b/dev-tex/lgrind/files/lgrind-3.67-fgets.patch
new file mode 100644
index 000000000000..5c8e802dc18a
--- /dev/null
+++ b/dev-tex/lgrind/files/lgrind-3.67-fgets.patch
@@ -0,0 +1,13 @@
+Index: lgrind/source/lgutil.c
+===================================================================
+--- lgrind.orig/source/lgutil.c
++++ lgrind/source/lgutil.c
+@@ -113,7 +113,7 @@ void Internal_Help_Language_List()
+ check=0;
+ if (*config=='\n' || config[strlen(config)-2]!='\\')
+ check=1;
+- if (fgets(config, BUFFERSIZE, tf)==NULL) break;
++ if (fgets(config, BUFFERSIZE/4, tf)==NULL) break;
+ if (check!=0) AddToLList(config, &currlch, &llch);
+ } while (strcmp((*currlch).name, "EndOfLanguageDefinitions")!=0);
+ rch=lch;
diff --git a/dev-tex/lgrind/lgrind-3.67-r3.ebuild b/dev-tex/lgrind/lgrind-3.67-r3.ebuild
new file mode 100644
index 000000000000..6b32572bed01
--- /dev/null
+++ b/dev-tex/lgrind/lgrind-3.67-r3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit latex-package toolchain-funcs eutils
+
+DESCRIPTION="A source pretty printer for LaTeX - styles to stylise your source and code examples"
+SRC_URI="mirror://gentoo/${PN}.tar.gz"
+
+LICENSE="BSD LGrind-Jacobson"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE="examples"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ echo 'CFLAGS+=-DDEFSFILE=\"$(DEFSFILE)\" -DVERSION=\"$(VERSION)\"' > source/Makefile
+ echo 'lgrind: lgrind.o lgrindef.o regexp.o' >> source/Makefile
+ epatch "${FILESDIR}/${P}-fgets.patch"
+}
+
+src_compile() {
+ tc-export CC
+
+ latex-package_src_compile
+ cd "${S}"/source
+ emake DEFSFILE="/usr/share/texmf/tex/latex/${PN}/lgrindef" VERSION="${PV}" || die
+}
+
+src_install() {
+ # binary first
+ dobin source/lgrind
+
+ # then the texmf stuff
+ latex-package_src_install
+ insinto /usr/share/texmf/tex/latex/${PN}
+ doins lgrindef
+
+ # and finally, the documentation
+ dodoc FAQ README
+ if use examples ; then
+ docinto examples
+ dodoc example/*
+ fi
+ cd "${S}"/source
+ doman lgrind.1 lgrindef.5
+}
diff --git a/dev-tex/lgrind/metadata.xml b/dev-tex/lgrind/metadata.xml
new file mode 100644
index 000000000000..ba6a8a8800d5
--- /dev/null
+++ b/dev-tex/lgrind/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tex</herd>
+</pkgmetadata>